Office カスタマイズ ツール ヘルプ ファイル

このヘルプ ファイルの内容は、2007 Microsoft Office system リソース キットの「2007 Office system の Office カスタマイズ ツール」で、オンラインでも参照できます。

概要 |
セットアップ |
インストール先と組織名 |
追加のネットワーク ソース | [ネットワーク サーバー エントリの追加] ダイアログ ボックス/[ネットワーク サーバー エントリの変更] ダイアログ ボックス
使用許諾契約とユーザー インターフェイス |
以前のインストール環境の削除 |
インストール環境の追加とプログラムの実行 | [プログラム エントリの追加]ダイアログ ボックス/[プログラム エントリの変更] ダイアログ ボックス
Office セキュリティ設定 |
セットアップのプロパティの変更 | [プロパティ値の追加/変更] ダイアログ ボックス
機能 |
ユーザー設定の変更 |
機能のインストール状況の設定 |
ファイルとレジストリ エントリ |
ファイルの追加 | [ファイルの保存先] ダイアログ ボックス
ファイルの削除 | [ファイルのパス] ダイアログ ボックス
レジストリ エントリの追加 | [レジストリ エントリの追加/変更] ダイアログ ボックス
レジストリ エントリの削除 |
ショートカットの構成 | [ショートカット エントリの追加/変更] ダイアログ ボックス
Outlook |
Outlook プロファイル |
Exchange Server 設定の指定 |
アカウントの追加 | [アカウントの追加] ダイアログ ボックス
アカウントの削除と設定のエクスポート |
送受信グループの指定 | [新しい Exchange グループ] ダイアログ ボックス
 | [グループの変更] ダイアログ ボックス
 | [Exchange グループ名の変更] ダイアログ ボックス


Office カスタマイズ ツール

Office カスタマイズ ツール (OCT) を使用して、2007 Microsoft Office system のインストールをカスタマイズします。OCT を実行するには、コマンド ラインで「setup.exe /admin」と入力します。

OCT を実行するとき、新しいセットアップ カスタマイズ ファイルを作成するか、既存のセットアップ カスタマイズ ファイルを開くかを選択します。新しいファイルを作成する場合は、ネットワーク インストール ポイントからインストール可能な製品の一覧が表示されます。カスタマイズ対象の製品は 1 つだけ選択します。

メモ OCT を実行するのに使用するコンピュータをはじめとして、2007 Office リリース を実行するすべてのコンピュータに Windows インストーラのバージョン 3.1 以降がインストールされている必要があります。Windows インストーラ 3.1 の入手方法などの詳細については、マイクロソフト サポート技術情報の記事 #893803 を参照してください。

OCT では、Office をカスタマイズし、カスタマイズした内容をセットアップ カスタマイズ ファイル (MSP ファイル) に保存し、このファイルをネットワーク インストール ポイントの Updates フォルダに置きます。Office をインストールするとき、セットアップによって Updates フォルダでセットアップ カスタマイズ ファイルが検索され、カスタマイズ ファイルが見つかると、そのファイルに保存されているカスタマイズ内容が適用されます。カスタマイズ ファイルが Updates フォルダ以外の場所にある場合は、セットアップのコマンド ライン オプション /adminfile を使用して、ファイルの完全修飾パスを指定できます。たとえば、「setup.exe /adminfile \\server\share\mychanges\custom.msp」のように指定します。

メモ カスタマイズ ファイルに Updates フォルダ以外のフォルダを使用する場合は、config.xml ファイルで、SetupUpdates 要素の SUpdateLocation 属性を使用してその場所を指定できます。詳細については、2007 Microsoft Office Resource Kit の「2007 Office system の Config.xml ファイル」を参照してください。

また、セットアップ カスタマイズ ファイルを使用して、既存のインストールを変更することもできます。セットアップ カスタマイズ ファイルは、Windows インストーラの MSP ファイル (拡張子が .msp のファイル) を拡張した形式であるため、ソフトウェアの更新と同様の方法で、ユーザーのコンピュータにカスタマイズ ファイルを適用でき、ユーザーの既存の Office インストールがカスタマイズの内容に従って更新されます。たとえば、ある機能のインストール状況を [利用不可能] に変更し、作成されたカスタマイズ ファイルを Office の既存のインストールに適用すると、その機能はユーザーのコンピュータから削除されます。

ただし OCT には、Office の新規インストールにのみ適用されるオプションもあります。これらのオプションは、OCT および OCT ヘルプ ファイルに示されています。たとえば、ユーザーのコンピュータ上で Office をインストールするフォルダは INSTALLLOCATION 要素で指定できますが、既存のインストールにカスタマイズ ファイルを適用する場合には、INSTALLLOCATION 要素は無視されます (インストール場所を変更するためには、Office をアンインストールして再インストールする必要があります)。

OCT を終了する前に、[ファイル] メニューの [保存] をクリックして、セットアップ カスタマイズ ファイルを保存します。

OCT は主に次の 4 つの部分に分けられます。各部分はいくつかのページから構成され、各ページにカスタマイズ可能なオプションが含まれています。

  • セットアップ - 既定の組織名、インストール先、追加のインストール ソースを指定し、プロダクト キーを設定し、使用許諾契約に同意します。表示レベルを設定し、削除する Office の以前のバージョンを選択し、インストール時に実行するカスタム プログラムを定義します。また、Office のセキュリティ設定をカスタマイズし、セットアップ プロパティを設定します。
  • 機能 - 既定のユーザー オプションを設定し、インストールする機能を選択します。
  • 追加内容 - カスタム ファイル、レジストリ エントリ、およびショートカットの追加または削除を行います。
  • Outlook - Microsoft Office Outlook 2007 の既定のプロファイルをカスタマイズし、Office Outlook 2007 と Microsoft Exchange 2007 のオプションを設定します。


インストール先と組織名

このセットアップ カスタマイズ ファイルをインストールに使用するすべてのユーザーの既定の組織名とインストール先を指定します。

既定のインストール先 - Office のインストール先となるユーザーのコンピュータ上の場所を指定します。定義済みのフォルダ キーワード [ProgramFilesFolder] を使用して、Microsoft Windows の標準フォルダのパスを指定できます。既定のパスは [ProgramFilesFolder]\Microsoft Office\ です。このオプションが認識されるのは、ユーザーのコンピュータに Office を最初にインストールするときのみです。インストール パスを変更するためには、Office のアンインストールおよび再インストールが必要です。
組織名 - この名前は、[バージョン情報] ボックス ([ヘルプ] メニュー) と Office アプリケーションのバナー ページに表示されます。指定した名前は、このカスタマイズ ファイルをインストールに使用するすべてのユーザーの既定の会社名として使用されます。


追加のネットワーク ソース

ネットワーク インストール ポイントのコピーが置かれた追加サーバーを指定します。

セットアップが必要時に応じて機能をインストールしたり、Office を修復したりするとき、本来のネットワーク インストール ポイントが利用できない場合は、この一覧のサーバーが指定順に検索されます。

一覧にソースを追加するには、[追加] をクリックします。パスを編集するには、一覧からサーバーを選択し、[変更] をクリックします。一覧からサーバーを削除するには、サーバーを選択し、[削除] をクリックします。一覧のサーバーの順序を変更するには、サーバーを選択し、[移動] の矢印をクリックしてサーバーを上下に移動します。

メモ OCT で一覧にサーバーを追加したときに、サーバーのパスが検証されたり、サーバーに接続が試行されたりすることはありません。


[ネットワーク サーバー エントリの追加] ダイアログ ボックス/[ネットワーク サーバー エントリの変更] ダイアログ ボックス

[ネットワーク サーバー エントリの追加] ダイアログ ボックスおよび [ネットワーク サーバー エントリの変更] ダイアログ ボックスで、ネットワーク サーバーのパスを入力し、[OK] をクリックします。

UNC パスに加え、すべてのユーザーがこのサーバーに同じドライブ文字でアクセスできる場合は、ドライブ文字を含んだパスも使用できます。すべてのユーザーに対して環境変数が定義されている場合は、パーセント記号 (%) で区切られた環境変数をパスに含めることができます。

たとえば、次のように指定します。

z:\office
\\server1\share\office_root
%USERNAME%\office_root


使用許諾契約とユーザー インターフェイス

このセットアップ カスタマイズ ファイルを使用して、Office をインストールする各ユーザーの代わりにプロダクト キーを入力し、使用許諾契約書 (EULA) に同意します。また、ユーザー インターフェイスの表示レベルを設定します。これらのオプションがセットアップによって認識されるのは、ユーザーのコンピュータに Office を最初にインストールするときのみです。

プロダクト キー - 有効な 25 文字のボリューム ライセンス キーを入力します。
「使用許諾契約書」の条項に同意します - ユーザーの代わりに使用許諾契約書の条項に同意するには、このチェック ボックスをオンにします。[表示レベル] が [基本] または [なし] に設定されている状態で、プロダクト キーを指定したときには、ユーザーの代わりに使用許諾契約書にも同意したものと見なされます。その場合、このチェック ボックスをオンにしなかったときでも、ユーザーには、インストール時または Office アプリケーションの最初の実行時に、使用許諾契約を求める確認のメッセージは表示されません。
表示レベル - インストール時にユーザー インターフェイスがどのように表示されるかを次の中から選択します。
  1. 詳細 - 既定 - セットアップが対話形式で実行され、ユーザー インターフェイスとメッセージがすべて表示されます。
  2. 基本 - ようこそ画面が表示され、プロダクト キーの入力と使用許諾契約への同意 (必要な場合) が求められます。また、インストールの進行状況を示すバーと完了通知が表示されます。
  3. なし - セットアップが対話なしで実行され、ユーザー インターフェイスは一切表示されません。
完了通知を表示する - インストールの完了時にユーザーにメッセージを表示する場合は、このチェック ボックスをオンにします。
入力項目を表示しない - インストールを中断することのあるエラー メッセージやダイアログ ボックスを表示しない場合は、このチェック ボックスをオンにします。[表示レベル] の [詳細] をクリックすると、このチェック ボックスの状態にかかわらずエラー メッセージとダイアログ ボックスが表示されます。

メモ 以下の OCT のオプションは、Config.xml ファイルの各設定項目に対応しています。

OCT のオプション | Config.xml の設定項目
プロダクト キー | PIDKEY 要素
使用許諾契約書の条項に同意する | Display 要素の AcceptEula 属性
表示レベル | Display 要素の Level 属性
完了通知を表示する | Display 要素の CompletionNotice 属性
入力項目を表示しない | Display 要素の SuppressModal 属性


以前のインストール環境の削除

以前のバージョンの Microsoft Office アプリケーションを保持するか、削除するかを指定します。このオプションがセットアップによって認識されるのは、ユーザーのコンピュータに Office を最初にインストールするときのみです。

既定では、セットアップによって以前のバージョンの Office アプリケーションはすべて削除されます。インストールされている Office アプリケーションを残すには、[次に示す以前のバージョンの Microsoft Office プログラムを削除する] を選択して、削除しない Office アプリケーションを指定します。次に、[詳細] をクリックしてチェック ボックスをオフにします。

メモ Office Outlook 2007 を以前のバージョンの Outlook と共存させることはできません。以前のバージョンを保持する場合は、Office Outlook 2007 をインストールしないでください。


インストール環境の追加とプログラムの実行

Office インストールの実行前または完了後に、追加の実行可能プログラムを実行します。

セットアップによってすべてのコマンド ラインが一覧の順序で実行されます。すべてのコマンド ラインの実行が完了するまでインストールは完了しません。

メモ 処理を完了するためにコンピュータを再起動する必要があるプログラムは必ず一覧の最後に指定してください。カスタム プログラムによりコンピュータが再起動されると、Office インストールは完了しますが、一覧内のそのプログラムより後に記載されているプログラムは実行されません。

一覧にプログラムを追加するには、[追加] をクリックします。プログラムを変更するには、プログラムを選択して [変更] をクリックします。プログラムを削除するには、プログラムを選択して [削除] をクリックします。一覧の順序を変更するには、プログラムを選択し、[移動] 矢印をクリックして一覧のプログラムを上下に移動します。


[プログラム エントリの追加] ダイアログ ボックス/[プログラム エントリの変更] ダイアログ ボックス

プログラム エントリを追加または変更する場合は、[プログラム エントリの追加] ダイアログ ボックスまたは [プログラム エントリの変更] ダイアログ ボックスで次の情報を入力し、[OK] をクリックします。

ターゲット - 実行可能プログラムのパスおよびファイル名を入力します。
引数 - コマンド ライン オプションの文字列を入力します (たとえば「/q /path c:\temp」)。
Office 製品のインストール後にこのプログラムを実行する (推奨) - Office インストールの完了後にプログラムが実行されます。これは推奨のオプションです。プログラムが正常に終了しない場合、またはプログラムによりコンピュータが再起動される場合でも、Office インストールには影響しません。ただし、一覧内のそのプログラムより後に記載されているプログラムは実行されません。
Office 製品のインストール前にこのプログラムを実行する - Office インストールの開始前にプログラムが実行されます。プログラムが正常に終了しない場合、またはプログラムによりコンピュータが再起動される場合は、Office がインストールされず、一覧内のそのプログラムより後に記載されているプログラムが実行されません。

[プログラム エントリの追加] ダイアログ ボックスまたは [プログラム エントリの変更] ダイアログ ボックスで、実行可能ファイルのパスに次の標準 Windows フォルダを含めることができます。

[SourceDir] | Office のインストール元であるネットワーク インストール ポイントのルート
[INSTALLLOCATION] | Office のインストール先フォルダ
[WindowsFolder] | Windows フォルダ
[SystemFolder] | Windows の System32 フォルダ
[ProgramFilesFolder] | Program Files フォルダ
[CommonFilesFolder] | Program Files\Common Files フォルダ
[DesktopFolder] | デスクトップ フォルダ
[StartMenuFolder] | スタート メニュー フォルダ
[ProgramMenuFolder] | スタート メニュー\プログラム フォルダ


セットアップのプロパティの変更

Office インストール中に適用するプロパティを設定します。セットアップのプロパティをカスタマイズできるのは、ユーザーのコンピュータに Office を最初にインストールするときのみです。既存のインストールにカスタマイズ ファイルを適用するときには、そのカスタマイズ ファイルで設定したプロパティは有効になりません。

プロパティを追加するには、[追加] をクリックします。追加したプロパティを変更するには、プロパティを選択して [変更] をクリックします。追加したプロパティを削除するには、プロパティを選択して [削除] をクリックします。

プロパティおよびその値の詳細については、「Setup properties in the 2007 Office system」 (英語) を参照してください。


[プロパティ値の追加/変更] ダイアログ ボックス

セットアップ プロパティを追加または変更するとき、[プロパティ値の追加/変更] ダイアログ ボックスで次の情報を入力し、[OK] をクリックします。

名前 - プロパティ名。プロパティ名はすべて大文字で指定する必要があります。
値 - プロパティの値。


ユーザー設定の変更

このカスタマイズ ファイルを使用して Office をインストールするユーザーの Office アプリケーション設定の既定値を設定します。

オプションを構成するには、左側のツリーを展開し、ユーザー インターフェイス要素をクリックします。そうすると、選択したユーザー インターフェイス要素に関連するすべての構成可能な設定が右側に表示されます。設定をダブルクリックして、次のいずれかのオプションを選択します。

未構成 - 設定はそのまま変更されません。
有効 - ダイアログ ボックスでの選択に基づいて、設定が変更されます。
無効 - 設定は無効になります。オプションを無効にすることと、オプションを構成しないことは、効果が異なる場合があります。詳細については、各オプションの説明を参照してください。

使用できるすべてのユーザー設定を表示するには、[全設定を表示] をクリックします。構成した設定のみを表示するには、[構成済みの設定のみを表示] をクリックします。

以前のバージョンの Office からユーザーのカスタム設定を維持するには、[ユーザー設定の移行] チェック ボックスをオンにします。ユーザー設定を変更し、このチェック ボックスもオンにすると、最初に変更後の設定が適用されてから、ユーザーの既存のカスタム設定が移行され、競合する設定がすべて上書きされます。

メモ [有効] をクリックして設定のオプションを表示し、[OK] をクリックするか、[前の設定] または [次の設定] をクリックすると、設定を変更しない場合でも、状態が [構成済み] に変更されます。誤って空のハイパーリンク、パス、またはファイル名を使用して設定を構成すると、エラーが発生する可能性があります。[有効] をクリックした後で、変更を無視したり、設定の構成を回避する場合は、[キャンセル] をクリックします。また、設定をダブルクリックし、[未構成] を選択後 [OK] をクリックすることで、設定の状態を [未構成] に戻すこともできます。


機能のインストール状況の設定

ユーザーのコンピュータへの Office 機能のインストール方法をカスタマイズします。

機能のインストール状況を変更するには、機能をクリックし、インストール状況を選択します。"親" 機能と呼ばれる一部の機能は、複数の "子" 機能で構成されます。子機能を表示するには、親機能の左側にあるプラス記号 (+) をクリックして展開します。

機能のインストール状況を変更すると、その機能の名前と、そのすべての子機能の名前が太字のフォントで表示され、セットアップによってそれらの変更がインストールに適用されることを示します。太字のフォントで表示されない機能は、既定のインストール状況を使用してインストールされます。加えた変更を削除するには、機能を選択し、[リセット] オプションを選択するか、[選択のリセット] をクリックします。

以下は、ユーザーがセットアップ時に通常利用できるインストール状況です。すべての機能ですべてのインストール状況を利用できるわけではありません。たとえば、アドバタイズできないコンポーネントが機能に含まれている場合、その機能の利用可能なインストール状況の一覧に [初めて実行するときにインストール] は含まれません。

マイ コンピュータから実行 | セットアップによって、ユーザーのハード ディスクに対し、インストールする機能に関連するファイルがコピーされ、レジストリ エントリとショートカットが書き込まれます。アプリケーションと機能はローカルに実行されます。
マイ コンピュータからすべて実行 | [マイ コンピュータから実行] と同じですが、機能に属しているすべての子機能もこの状態に設定される点が異なります。
初めて実行するときにインストール | その機能とすべての子機能のコンポーネントはインストール ソースに残され、ユーザーが機能を初めて使用するときにローカル ハード ディスクにコピーされます。これは "アドバタイズ" 機能とも呼ばれます。
インストールしない | 機能、およびこの機能に属している子機能のコンポーネントがいずれもコンピュータにインストールされません。

各機能では、次のオプションも使用できます。

非表示 | セットアップが対話的に実行されている場合は、インストール中、機能ツリーに機能が表示されません。Office のインストール後に、セットアップが "メンテナンス モード" で実行されている場合は、機能は非表示になりません。機能が非表示であることを示すため、"H" という記号が機能名の先頭に追加されます。
ロック | インストール実行時、または Office インストール後のメンテナンス モード実行時、ユーザーはこの機能に対して選択されたインストール状況を変更できません。機能がロックされていることを示すため、"L" という記号が機能名の先頭に追加されます。
リセット | 機能は、既定のインストール状況に戻ります。機能を選択して [選択のリセット] ボタンをクリックすることと同じ効果が適用されます。

機能を明示的に既定の状態に設定する場合は、機能が既定の状態に強制的に設定されることを示すため、"F" という記号が機能名の先頭に追加されます。これは、セットアップ カスタマイズ ファイルを作成して、既に実行された Office のインストールを修正する場合に便利です。機能のインストール状況を変更しなかった場合は、セットアップによってユーザーのコンピュータで機能が変更されることはありません。一方、変更を指定した場合は (機能を通常の既定の状態に設定するように指定した場合も含みます)、ユーザーのコンピュータではセットアップによって機能が指定された状態に設定されます。

機能のインストール状況を変更すると、セットアップによって親機能または子機能のインストール状況が一致するように変更されます。たとえば、親機能を [初めて実行するときにインストール] に設定し、子機能を [マイ コンピュータから実行] に設定すると、セットアップにより親機能の状況も [マイ コンピュータから実行] に変更されます。

ユーザーがセットアップを対話的に実行すると、非表示の機能は、機能ツリーには表示されませんが、それに対して定義されているインストール状況に応じてインストールされます。機能を非表示にすると、その機能に属している子機能もすべて非表示になります。

表示 ヒント

[非表示] の最も有効な利用方法は、ユーザーの機能ツリーを簡略化することです。たとえば、ユーザーが必要なツールを特定しなくて済むように、機能ツリーの [Office ツール] 以下の項目を非表示にすることがあります。この場合は、選択したツールのみがインストールされます。

機能を [インストールしない] に設定し、機能ツリーで非表示にした場合でも、ユーザーは親機能をインストールするか、セットアップをメンテナンス モードで実行して、その設定を変更し、機能をインストールできます。たとえば、[名前用スマート タグ プラグイン] 機能を [インストールしない] と [非表示] に設定した場合でも、ユーザーは親の [スマート タグ プラグイン] 機能を [マイ コンピュータからすべて実行] に設定してその機能をインストールできます。ユーザーが非表示の機能をインストールできないようにする場合は、[インストールしない]、[非表示]、および [ロック] をクリックします。この場合、機能またはアプリケーションはインストールされず、メンテナンス モードで使用できません。ユーザーが、親機能の状況を変更してこの機能またはアプリケーションをインストールすることはできません。Office のインストール後に [インストールしない]、[非表示]、および [ロック] を無効にするには、OCT を使用して、機能のインストール状況を変更するように構成したセットアップ カスタマイズ ファイルを作成し、そのカスタマイズ ファイルをユーザーのコンピュータに適用する方法しかありません。


ファイルの追加

Office のインストール時にユーザーのコンピュータにファイルを追加します。

インストール中にユーザーのコンピュータに追加するファイルの一覧を作成するには、[追加] をクリックし、一覧に追加するファイルを選択して、[追加] を再度クリックします。ファイルの保存先を変更するには、[ファイルの追加] ボックスの一覧でファイルを選択し、[変更] をクリックします。一覧からファイルを削除するには、ファイルを選択し、[削除] をクリックします。Shift キーと Ctrl キーを使用すると、複数のファイルを一度に選択できます。

Office インストールにファイルを追加するときは、次の点に注意してください。

  • セットアップ カスタマイズ ファイルを保存して OCT を終了すると、カスタマイズ ファイルにファイルがコピーされます。各ファイルのサイズが大きいと、カスタマイズ ファイルのサイズも大きくなり、作成にかかる時間も長くなります。
  • 現在カスタマイズ ファイルに含まれているファイルを変更する場合は、OCT を使用してカスタマイズ ファイルを開き、[ファイルの追加] ボックスの一覧からファイルを削除します。次に、変更したファイルを追加して、カスタマイズ ファイルを保存します。
  • ユーザーが Office を削除、修復、または再インストールすると、追加されたファイルは Office と共に削除または再インストールされます。ただし、インストール後に変更されているファイルは再インストールされません。


[ファイルの保存先] ダイアログ ボックス

[ユーザーのコンピュータ上での保存先] ダイアログ ボックスで、ユーザーのコンピュータ上でのファイルのインストール先フォルダを入力し、[OK] をクリックします。

Shift キーと Ctrl キーを使用して、複数のファイルを一度に選択することができます。これらのファイルは、同じ保存先フォルダに関連付けられます。保存先のパスに次の特別なフォルダ名を使用できます。

[INSTALLLOCATION] | Office のインストール先フォルダ
[ROOTDRIVE] | 空き容量が一番大きいローカル ディスク ドライブ
[ProgramFilesFolder] | Program Files フォルダ
[CommonFilesFolder] | Program Files\Common Files フォルダ
[WindowsFolder] | Windows フォルダ
[SystemFolder] | Windows の System32 フォルダ
[PersonalFolder] | ユーザーのマイ ドキュメント フォルダ
[AppDataFolder] | ユーザーの Application Data フォルダ
[NetHoodFolder] | ユーザーのマイ ネットワーク フォルダ


ファイルの削除

Office のインストール時にユーザーのコンピュータからファイルを削除します。

インストール中にユーザーのコンピュータから削除するファイルの一覧を作成するには、[追加] をクリックします。ファイルのパスまたは名前を変更するには、[ファイルの削除] ボックスの一覧でファイルを選択し、[変更] をクリックします。一覧からファイルを削除するには、ファイルを選択し、[削除] をクリックします。Shift キーと Ctrl キーを使用すると、複数のファイルを一度に選択できます。

メモ [ファイルの追加] ボックスの一覧に表示されているファイルがインストールされる前に、[ファイルの削除] ボックスの一覧に表示されているファイルがユーザーのコンピュータから削除されます。そのため、ユーザーのコンピュータにある既存のファイルを削除し、新しいバージョンのファイルと置き換えることができます。ユーザーのコンピュータにある該当のファイルが変更されていたりファイル名が変わっている場合、変更前の名前でファイルを追加しても、既存のファイルが置き換えられることはありません。


[ファイルのパス] ダイアログ ボックス

[ファイルのパス] ダイアログ ボックスで、ユーザーのコンピュータから削除するファイルの一覧に追加するファイルのパスおよびファイル名を入力して、[OK] をクリックします。

パスの先頭には、ドライブ文字、UNC パス、または次に示す特別なフォルダの中の 1 つを指定する必要があります。

[INSTALLLOCATION] | Office のインストール先フォルダ
[ROOTDRIVE] | 空き容量が一番大きいローカル ディスク ドライブ
[ProgramFilesFolder] | Program Files フォルダ
[CommonFilesFolder] | Program Files\Common Files フォルダ
[WindowsFolder] | Windows フォルダ
[SystemFolder] | Windows の System32 フォルダ
[PersonalFolder] | ユーザーのマイ ドキュメント フォルダ
[AppDataFolder] | ユーザーの Application Data フォルダ
[NetHoodFolder] | ユーザーのマイ ネットワーク フォルダ


レジストリ エントリの追加

Office のインストール時にユーザーのコンピュータのレジストリ エントリを追加または変更します。

ユーザーのコンピュータに追加するレジストリ エントリの一覧を作成するには、[追加] をクリックします。一覧のエントリを変更するには、エントリを選択して [変更] をクリックします。一覧からエントリを削除するには、エントリを選択して [削除] をクリックします。レジストリ ファイル (REG ファイル) から一連のエントリを追加するには、[インポート] をクリックします。REG ファイルのエントリが一覧のエントリと重複する場合、既存のレジストリ エントリを REG ファイルのレジストリ エントリで上書きするかどうかを選択するように要求されます。

メモ このセクションでカスタマイズしたレジストリ エントリは、OCT の他のどの方法でカスタマイズした設定よりも優先されます。Office ユーザー インターフェイスで直接設定したり、OCT の他の方法を使用して構成したりすることができないオプションをカスタマイズするには、このセクションを利用してください。


[レジストリ エントリの追加/変更] ダイアログ ボックス

[レジストリ エントリの追加/変更] ダイアログ ボックスで、各レジストリ エントリについて、以下の情報を入力し、[OK] をクリックします。

ルート - 追加または変更するエントリを含む分岐を選択します。設定はユーザーごとに 1 回 (HKEY_CURRENT_USER) またはコンピュータごとに 1 回 (HKEY_LOCAL_MACHINE) 適用されます。HKEY_USERS または HKEY_LOCAL_MACHINE のルートにはレジストリ エントリを追加できないことに注意してください。
データ型 - レジストリ値のデータ型を選択します。
キー - エントリを格納するサブキーの名前を入力します。たとえば、「Software\Microsoft\Office\12.0\Common」と入力します。
空のキーを作成する - レジストリ エントリに値の名前や値データを含めない場合は、このチェック ボックスをオンにします。一部の設定は、レジストリ エントリの有無によって決定されます。
値の名前 - 新しいレジストリ エントリの名前を入力します。[値データ] には値を入力し、このフィールドは空白のままにすると、値に <既定> という名前が割り当てられます。1 つのキーには <既定> という値の名前を 1 つしか割り当てられません。
値データ - 新しいレジストリ エントリに格納するデータ (値) を入力します。このデータはデータ型と一致する必要があります。


レジストリ エントリの削除

Office のインストール時にユーザーのコンピュータからレジストリ エントリを削除します。

ユーザーのコンピュータから削除するレジストリ エントリの一覧を作成するには、[追加] をクリックし、レジストリ エントリごとに次の情報を入力します。

ルート - 削除するエントリを含む分岐を選択します。
キー - エントリが格納されているサブキーの完全な名前を入力します。たとえば、「Software\Microsoft\Office\12.0\Common」と入力します。
値の名前 - 削除するレジストリ エントリの名前を入力します。サブキー全体 (すべての値のエントリを含む) を削除する場合は、このフィールドを空白のままにします。

メモ ユーザーが Office を削除、修復、または再インストールすると、Office と共にカスタム レジストリ エントリも削除または再インストールされます。


[レジストリ エントリの削除/変更] ダイアログ ボックス

[レジストリ エントリの削除/変更] ダイアログ ボックスで、各レジストリ エントリに対して次の情報を入力し、[OK] をクリックします。

[ルート] - 削除するエントリを含む分岐を選択します。
[キー] - エントリを格納するサブキーの名前を入力します。たとえば、「Software\Microsoft\Office\12.0\Common」と入力します。
[値の名前] - 削除するレジストリ エントリの名前を入力します。サブキー全体 (すべての値のエントリを含む) を削除する場合は、このフィールドを空白のままにします。


Outlook プロファイル

既定の Outlook プロファイルをカスタマイズします。Outlook プロファイルは、ユーザー固有の情報を定義する Windows レジストリの値のセットです。Outlook プロファイルには、複数の電子メール アカウントを含むことができます。各ユーザーが複数の Outlook プロファイルを持っている可能性がありますが、セットアップ カスタマイズ ファイルでは、プロファイルを 1 つしか構成できません。

既存のプロファイルを使用 - ユーザーのコンピュータで既に構成されているプロファイルを使用するか、プロファイルが構成されてない場合は、ユーザーが Outlook を初めて起動するときにプロファイルの作成を促すメッセージを表示します。このオプションを選択すると、OCT の他の Outlook セクションが無効になります。
プロファイルの変更 - ユーザーのコンピュータ上の既定のプロファイルを変更するか、指定する名前でプロファイルへの変更を定義します。既定のプロファイルが存在しないか、指定する名前のプロファイルが存在しない場合は、OCT の他の Outlook セクションで選択したオプションに基づいてプロファイルが作成されます。プロファイルには、既定のプロファイル名 ("Outlook") または指定したプロファイル名が使用されます。
新しいプロファイル - ユーザーのコンピュータに新しいプロファイルを作成し、そのプロファイルを既定のプロファイルにします。既存のプロファイルは削除されず、ユーザーが引き続き利用できます。[プロファイル名] ボックスに名前を入力してください。この名前は、Outlook の [電子メール アカウント] ダイアログ ボックスに表示されます。新しいプロファイルが、OCT の他の Outlook セクションで選択したオプションに基づいて作成されます。
PRF の適用 - Outlook プロファイル ファイル (PRF ファイル) をインポートして新しい既定のプロファイルを定義します。このオプションを選択すると、OCT の他の Outlook セクションが無効になりますが、OCT の設定が PRF ファイル内の設定に変更されることはありません。Office Outlook 2007 用に作成した任意のプロファイルを使用できます。[次のプロファイル (PRF ファイル) を適用] ボックスにプロファイルの名前とパスを入力してください。Outlook の以前のバージョンで作成した PRF ファイルがあり、プロファイルで MAPI サービスだけが定義されている場合は、その PRF ファイルを Office Outlook 2007 にインポートできます。

ロックされたコンピュータに Office をインストールすると、そのコンピュータの管理者の権限のないユーザーは、Office のインストール後、自分の Outlook プロファイルを構成できません。


Exchange Server 設定の指定

新規または変更後の Outlook プロファイルの Microsoft Exchange の設定を構成します。

Exchange Server 接続

新規または既存のプロファイルの Exchange Server 接続を構成します。

Exchange Server 接続を構成しない - プロファイルがコンピュータに存在しない場合、ユーザーが Outlook を初めて起動するときに、使用するプロファイルとアカウント情報を確認します。
Exchange Server 接続を構成する - 新しい Exchange Server 接続の設定を構成するか、既存の Exchange Server 接続を変更します。次の情報を入力してください。
  • ユーザー名 - 特定の値または置き換え可能なパラメータでユーザーを識別します。既定の置き換え可能なパラメータ %USERNAME% を指定すると、Outlook の起動時にユーザーに候補が示されずに、ユーザーのログオン名がそのまま使用されます。
  • Exchange Server - ユーザーが Outlook を起動するときに稼働している可能性のある Exchange サーバーの名前を入力します。ユーザーが Outlook を初めて起動するとき、この値がユーザーの正しい Exchange サーバーに置き換えられます。このテキスト ボックスには、Exch-2-Srvr のように、サーバー名だけを入力してください。円記号 (\\) や同様の構文を含むことはできません。
  • Exchange Server 接続が存在する場合は、既存の Exchange 設定を上書きする - ユーザーのプロファイルに既に存在する Exchange Server アカウントをこのアカウントに置き換える場合は、このチェック ボックスをオンにします。

Exchange キャッシュ モード

次のオプションを使用して、Exchange メールボックスのローカル コピーを使用するようにユーザーの Outlook プロファイルを構成します。

Exchange キャッシュ モードを構成しない - 既定では、ユーザーのコンピュータのオフライン ストア ファイル (OST ファイル) にキャッシュされたコピーではなく、Exchange サーバーにある Exchange メールボックスが使用されます。
Exchange キャッシュ モードを構成する - OST ファイルを作成するか、既存の OST ファイルを使用します。ユーザーは、自分の Exchange メール ボックスのローカル コピーを使用します。[Exchange キャッシュ モードを使用する] チェック ボックスをオンにした場合、次のオプションを使用してユーザーの Exchange キャッシュ モードを構成できます。
ヘッダーのみをダウンロードする - ユーザーの Exchange メール ボックスからヘッダーのコピーのみをダウンロードします。
ヘッダーに続いてアイテム全体をダウンロードする - ユーザーの Exchange メールボックスからヘッダーのコピーをダウンロードした後、メッセージのコピーをダウンロードします。
アイテム全体をダウンロードする - ユーザーの Exchange メールボックスからメッセージ全体 (ヘッダーとメッセージ本文) のコピーをダウンロードします。
低速回線接続ではヘッダーのみをダウンロードする - 低速ネットワーク接続が検出されたときは、ユーザーの Exchange メールボックスからヘッダーのコピーのみをダウンロードします。
メール フォルダ以外の共有フォルダをダウンロードする - メール フォルダ以外の共有フォルダをダウンロードします。
パブリック フォルダのお気に入りフォルダをダウンロードする - パブリック フォルダのお気に入りフォルダの一覧をダウンロードします。


その他の Exchange Server 設定

Exchange Server をオフラインで使用するためのオプションと、Outlook Anywhere 機能を構成します。これらの設定を構成する方法の詳細については、2007 Microsoft Office リソース キットの「Configuring Cached Exchange Mode with Outlook 2007」を参照してください。


アカウントの追加

ユーザーのプロファイルに新しい Outlook 電子メール アカウントを追加します。

新規または変更後の Outlook プロファイルにアカウントを追加しない場合は、[Outlook プロファイルとアカウント情報をカスタマイズしない] をクリックします。

新規または変更後の Outlook プロファイルで新しいアカウント情報を指定する場合は、[Outlook プロファイルとアカウント情報をカスタマイズする] をクリックします。ユーザーがアプリケーションを初めて起動するとき、ユーザーが指定した情報に基づいてプロファイルが作成されます。

新しいアカウントを一覧に追加するには、[追加] をクリックします。一覧内のアカウントを変更するには、アカウントを選択し、[変更] をクリックします。一覧からアカウントを削除するには、アカウントを選択し、[削除] をクリックします。

次のオプションを指定することもできます。

  • 新着メールが配信される場所 - Exchange サーバーを構成するとき、または個人用フォルダ ファイル (PST ファイル) を追加するときは、このチェック ボックスをオンにして、新しい電子メール メッセージの配信場所を指定します。既定の場所は、Exchange サーバーが指定されている場合はそのサーバー、それ以外の場合はユーザーのコンピュータ上の PST ファイルです。
  • 既定の電子メール アカウント - ユーザーの既定の電子メール アカウントにするアカウントを選択します。


[アカウントの追加と [アカウント設定]] ダイアログ ボックス

新しいアカウントを追加する場合は、追加するアカウントの種類を選択し、[次へ] をクリックします。

[<アカウントの種類> の設定] ダイアログ ボックスで、追加または変更するアカウントの種類に適したオプション (アカウント名、ユーザー名、メール サーバー、電子メール アドレスなど) を設定します。その他の構成オプションを設定する場合は、[詳細設定] をクリックします。設定が完了したら [完了] をクリックします。

電子メール サービスが重複しないように、Outlook では、同じ種類のサービスで複数の新規アカウントを追加できないことがあります。たとえば、各 POP アカウントの名前が他と重複していないことが確認されます。次の表は、既存アカウントと同じ種類の新規アカウントをセットアップ カスタマイズ ファイルに追加できるかどうかの判断に使用されるデータを示しています。

アカウントの種類 | 重複するアカウントの追加の可否 | サービスが重複しているかどうかの判断に使用されるデータ
POP3 | いいえ | アカウント名
IMAP | いいえ | アカウント名
Hotmail または HTTP | いいえ | アカウント名
PST | いいえ | PST ファイルの名前とパス
Unicode PST | いいえ | Unicode PST ファイルの名前とパス
Outlook アドレス帳 | はい | アカウントの存在
個人用アドレス帳 | はい | アカウントの存在
LDAP | いいえ | アカウント名
Exchange | はい | プロバイダの存在


アカウントの削除と設定のエクスポート

既存の電子メール アカウントを削除するか、設定を PRF ファイルにエクスポートします。

アカウントを削除するオプションは、OCT の [Outlook プロファイル] ページで [プロファイルの変更] が選択されている場合にのみ使用できます。[以下のアカウントがある場合は削除する] で [Lotus cc:Mail] または [Microsoft Mail] をクリックすると、Outlook が初めて起動するときにユーザーのコンピュータから該当するアカウントが削除されます。

PRF ファイルで定義した Outlook プロファイル設定を保存するには、[プロファイル設定のエクスポート] をクリックします。

表示 ヒント

Outlook PRF ファイルを効率的に作成するには、OCT を使用して選択を行った後、その選択内容を PRF ファイルにエクスポートします。この方法は、Office を展開するときにセットアップ カスタマイズ ファイルを使用しない場合でも有効です。PRF ファイルを編集して、OCT では設定できない項目をカスタマイズできます。たとえば、OCT で示される一覧にない電子メール プロバイダを追加できます。


送受信グループの指定

Exchange のアカウントとフォルダの送受信グループを定義し、Outlook で送受信の実行中に各グループで行うタスクを指定します。送受信グループには、Outlook のアカウントとフォルダのコレクションが含まれます。Outlook がオンラインの場合、および Outlook がオフラインの場合の送受信グループのさまざまなオプションを指定できます。

送受信設定を構成しない - 送受信グループの設定を構成しません。この場合、Outlook は、"すべてのアカウント" グループとその既定の設定だけで構成されます (以前のバージョンでユーザーが追加したグループは、Office Outlook 2007 にアップグレードするときに移行されます)。
送受信設定を構成する - 送受信グループの設定 (Exchange のアカウントとフォルダのみ) を構成します。
  • アカウントとフォルダの新しいグループを作成するには、[新規作成] をクリックします。
  • 送受信グループのオプションを指定または変更するには、[変更] をクリックします。
  • 既存の送受信グループの名前を変更するには、[名前の変更] をクリックします。
  • 既存の送受信グループを削除するには、[削除] をクリックします。

選択したグループの送受信の設定

一覧で選択した送受信グループの設定を指定します (選択したグループの名前がオプション ラベルに表示されます)。Outlook がオンラインまたはオフラインのときのさまざまな設定を指定できます。

Outlook がオンラインのとき
  • このグループを送受信に含める - ユーザーが [送受信] をクリックしたとき、このグループの送受信を実行します。
  • 次の時間ごとに自動的に送受信を実行する - 送受信を実行する間隔を選択します。
  • 終了時に自動的に送受信を実行する - ユーザーが Outlook を終了するときにこのグループの送受信を自動的に実行します。
Outlook がオフラインのとき
  • このグループを送受信に含める - ユーザーが [送受信] をクリックしたとき、このグループの送受信を実行します。
  • 次の時間ごとに自動的に送受信を実行する - 送受信を実行する間隔を選択します。
Exchange アドレス帳
  • オフライン アドレス帳をダウンロードする - ユーザーが [送受信] をクリックしたとき、オフライン アドレス帳をダウンロードします。
  • [アドレス帳の設定] をクリックして、[アドレス帳の設定の変更] ダイアログ ボックスを開きます。[前回の送受信以降の変更をダウンロードする] チェック ボックスをオンにすると、前回のダウンロード以降に加えられたアドレス帳の更新内容のみをダウンロードできます。アドレス帳の詳細情報をダウンロードする場合は [全詳細情報]、詳細情報をダウンロードしない場合は [詳細情報なし] をクリックします。


[新しい Exchange グループ] ダイアログ ボックス

作成する Exchange 送受信グループの名前を [新しいグループ名] ボックスに入力し、[OK] をクリックします。


[グループの変更] ダイアログ ボックス

グループを変更するときは、[グループの変更] ダイアログ ボックスで次のオプションを選択し、[OK] をクリックします。

[この送受信グループのオプションを選択してください] で次のオプションを選択します。

メール アイテムを送信する - このグループの送受信を実行するときに、送信トレイからメール アイテムを送信します。
メール アイテムを受信する - このグループの送受信を実行するときに、メール アイテムを受信します。
フォルダのホーム ページをオフラインで使用可能にする - このグループの送受信を実行するときにフォルダ ホーム ページの内容を更新します。
フォームを同期する - このグループの送受信を実行するときにフォームを同期します。

[この送受信グループのフォルダ オプションを変更してください] でフォルダを選択し、次の情報を入力します。

このフォルダを送受信に含める - この送受信グループの送受信で更新するフォルダのセットにこのフォルダを追加し、次のオプションを選択します。
  • ヘッダーのみをダウンロードする - この送受信グループの送受信を実行して更新するときに、フォルダのヘッダーのみをダウンロードします。
  • 添付ファイルを含むアイテム全体をダウンロードする - この送受信グループの送受信を実行して更新するときに、このフォルダの電子メール (または他のアイテム) 全体をダウンロードします。
  • 次のサイズより大きいアイテムについてはヘッダーのみダウンロードする - 指定したサイズよりアイテムが大きいときは、アイテムのヘッダーのみをダウンロードします。この設定は、この送受信グループの送受信を実行して更新するときにこのフォルダにのみ適用されます。


[Exchange グループ名の変更] ダイアログ ボックス

Exchange 送受信グループの新しい名前を [新しいグループ名] ボックスに入力し、[OK] をクリックします。


[アドレス帳の設定の変更] ダイアログ ボックス

オフライン アドレス帳を最新の状態に保つための既定の方法を構成します。次のオプションの中から選択します。

[前回の送受信以降の変更をダウンロードする]: 前回の送受信以降にアドレス帳に加えられた変更だけをダウンロードします。通常、ダウンロードにかかる時間は、アドレス帳全体をダウンロードする場合よりも短くなります。
[完全な詳細情報]: アドレス帳をダウンロードするとき、各エントリの詳細情報をすべてコピーします。
[詳細情報なし]: アドレス帳をダウンロードするとき、名前や電子メール アドレスなど、各エントリの基本情報だけをコピーします。ダウンロードにかかる時間は短くなりますが、アドレスの詳細情報はオフライン アドレス帳に格納されません。


Office セキュリティ設定

Office アプリケーションのセキュリティ設定をカスタマイズします。

メモ セットアップ カスタマイズ ファイルで指定するセキュリティ設定は、ユーザーのコンピュータでの既定の設定になりますが、インストール後にユーザーが変更できます。セキュリティ設定をロックするには、グループ ポリシーを使用します。詳細については、「Locking down computers for the 2007 Office system」 (英語) を参照してください。

信頼できる発行元 - 信頼できる発行元の一覧を管理します。これらの発行元からのデジタル署名されたマクロ、アドイン、Microsoft ActiveX コントロール、およびその他の実行可能コードを Office アプリケーションで使用します。Office アプリケーションは、証明書に基づく信頼できる発行元の一覧を Internet Explorer と共有します。[追加] をクリックしてデジタル証明書 (CER ファイル) ファイルを追加します。既定の Microsoft CER ファイルを追加すると、Office アプリケーションと共にすべてのアドインとテンプレートがユーザーのコンピュータにインストールされます。
信頼できる場所 - 信頼できる場所の一覧を管理します。これらの場所に置かれているファイルは、セキュリティ センターのセキュリティ機能でチェックすることなく開くことができます。[追加] をクリックして新しい場所を入力し、次の情報を入力し、[OK] をクリックします。
アプリケーション - この場所を使用する Office アプリケーションを選択します。
パス - 信頼できる場所のパスを入力します。ドライブ文字または UNC パスを含む完全修飾パスを入力してください。パスには、環境変数を含むことができます。
この場所のサブフォルダも信頼する - サブフォルダも信頼できる場所と見なす場合はこのチェック ボックスをオンにします。
説明 - この場所の目的を説明する文字列を入力します。

この一覧から信頼できる場所を削除するには、その場所を選択して [削除] をクリックします。

メモ ここで信頼できる場所を指定すると、ユーザーのコンピュータで既に定義されている信頼できる場所の一覧が削除され、この一覧に置き換えられます。

Office カスタマイズ ツールによって書き込まれた信頼できる場所を、インストール中にすべて削除する - ユーザーのコンピュータ上の信頼できる場所の一覧を削除します。新しい場所を追加せず、ユーザーのコンピュータにある信頼できる場所の一覧を削除する場合は、このチェック ボックスをオンにします。
既定のセキュリティ設定 - アドイン、テンプレート、および Office アプリケーションの既定のセキュリティ レベルを設定します。次のオプションを Office アプリケーションごとに設定できます。
  • 許可された信頼できる場所のオプション
    1. ユーザーのコンピュータ以外の信頼できる場所を許可する
    2. 信頼できる場所をすべて無効にする (信頼できる発行元によって署名されたファイルのみが信頼されます)
  • アプリケーション拡張の警告オプション
    1. すべてのアプリケーション拡張を無効にする
    2. アプリケーション拡張に対し、信頼できる発行元の署名を必須にする
    3. アプリケーション拡張の署名を必須にし、署名されていない拡張は通知せずに無効にする
  • VBA マクロの警告オプション
    1. すべての VBA マクロを無効にする
    2. 署名されていない VBA マクロに関するセキュリティ バーの警告を無効にする (署名されていないコードは無効になります)
    3. VBA マクロに対しセキュリティ チェックを行わない (推奨しません。全ドキュメントに含まれるコードが実行される可能性があります)
  • アドインとテンプレート (Microsoft Office Project 2007 のみ)
    1. 組み込み済みのアドインとテンプレートをすべて信頼する
    2. インストールされたアドインとテンプレートを信頼しない
  • セキュリティ レベル (Office Project 2007 のみ)
    1. 高: 信頼できる作成元からの署名付きのマクロだけを実行することができます。署名のないマクロは自動的に実行不可になります。
    2. 中: コンピュータに損害を与える可能性があるマクロを実行する前に警告を表示します。
    3. 低 (推奨しません): コンピュータに損害を与える可能性があるマクロを実行する前に警告を表示しません。
安全でない ActiveX の初期化 - 署名されていないため、安全でない可能性のある ActiveX コントロールが、持続的なデータ (コントロールのインスタンスとその次のインスタンスの間で保存されるデータ) を使用して初期化できるかどうかを決定します。指定できる値は次のとおりです。
<構成しない> - ユーザーのコンピュータで指定されている設定を変更しません。ユーザーのコンピュータに初めてインストールされるアプリケーションは、既定の設定、[持続的なデータの使用を指示するメッセージをユーザーに対して表示する] でコンピュータにインストールされます。
コントロールの既定値の使用を指示するメッセージをユーザーに対して表示する - 安全でない可能性のある ActiveX コントロールをアプリケーションが初期化する前にユーザーに警告します。ユーザーがドキュメントの発行元を信頼する場合、コントロールはその既定の設定で初期化されます。
持続的なデータの使用を指示するメッセージをユーザーに対して表示する 安全でない可能性のある ActiveX コントロールをアプリケーションが初期化する前にユーザーに警告します。ユーザーがドキュメントの発行元を信頼する場合、コントロールは持続的なデータを使用して初期化されます。
メッセージを表示しない - 署名されていない ActiveX コントロールをすべて、メッセージを表示せずに実行します。この設定はシステムの保護が最小限になるため、お勧めしません。


ショートカットの構成

インストールした Office アプリケーションに対する既定のショートカットの変更または削除、および、2007 Office リリース と共にインストールされるファイルまたは既にユーザーのコンピュータ上にあるファイルに対するショートカットの追加を行います。

新しいショートカットを追加するには、[追加] をクリックします。一覧内のショートカットを変更するには、ショートカットを選択し、[変更] をクリックします。一覧からショートカットを削除するには、ショートカットを選択し、[削除] をクリックします。

メモ カスタムのアプリケーションまたはファイルに対するショートカットを追加した場合、ユーザーが Office の変更、修復、再インストール、または削除を行っても、そのショートカットの更新や削除は行われません。


[ショートカット エントリの追加/変更] ダイアログ ボックス

[ショートカット エントリの追加/変更] ダイアログ ボックスで、作成または変更するショートカットに関する以下の情報を入力し、[OK] をクリックします。

ターゲット - 定義済みのアプリケーション キーワードを選択するか、またはショートカットが指すファイルの名前とパスを入力して、ショートカットと関連付けるアプリケーションを指定します。アプリケーション キーワードを選択した場合、残りのボックスの情報は自動的に入力されます。一覧の名前は、OCT の [機能のインストール状況の設定] ページで選択する機能、および [ファイルの追加] ページでインストールに追加するカスタム ファイルに対応します。名前とパスを入力する場合、名前またはパスにスペースが含まれるときには、文字列全体を二重引用符 ("") で囲む必要があります。[引数] フィールドを使用すると、アプリケーションに渡すコマンド ライン オプションを追加できます。
場所 - 定義済みのフォルダ キーワードを選択するか、またはショートカットを作成するフォルダの名前とパスを入力して、ショートカットを作成する場所を指定します。サブフォルダを指定するには、円記号 (\) を付加した後にサブフォルダの名前を指定します。たとえば、[スタート メニュー] の [プログラム] フォルダの [Microsoft Office] サブフォルダに Microsoft Office Word 2007 のショートカットをインストールするには、[ProgramMenuFolder] を選択し、サブフォルダの名前を「[ProgramMenuFolder]\Microsoft Office」のように追加します。

[場所] では、次の特別なフォルダを使用できます。

[StartMenuFolder] | スタート メニュー フォルダ
[ProgramMenuFolder] | スタート メニュー\プログラム フォルダ
[StartupFolder] | スタート メニュー\プログラム\スタートアップ フォルダ
[DesktopFolder] | デスクトップ フォルダ
[INSTALLLOCATION] | Office のインストール先フォルダ
[FavoritesFolder] | ユーザーのお気に入りフォルダ
[AppDataFolder] | ユーザーの Application Data フォルダ
[NetHoodFolder] | ユーザーのマイ ネットワーク フォルダ
名前 - ショートカットの名前を表す文字列を指定します。
Start in - アプリケーションの既定の作業フォルダを表すパスを指定します。このボックスを入力しなかった場合、ターゲット ファイルが存在するフォルダが既定のフォルダに設定されます。指定したパスがユーザーのコンピュータで有効でない場合、ユーザーがショートカットを使用するときにエラー メッセージが表示されます。
引数 - コマンド ラインでアプリケーションに渡すオプションの引数を入力します。
ショートカット キー - アプリケーションまたはファイルを起動するためのオプションのショートカット キーを入力します。ショートカット キーの構文は、次のとおりです。
[modifier+]VK_key
ここで、modifier は補助キー (Shift キー、Ctrl キー、Alt キー、または Ext キー) で、VK_key は仮想キーです (次の表を参照してください)。補助キーは省略でき、また複数の補助キーを任意の順序で正符号 (+) で区切って指定することもできます。補助キーを使用する場合は、"補助キー + 仮想キー" の順序で指定します。仮想キーは必ず指定する必要があります。ショートカット キーの定義では、スペースを使用しないでください。

ここに例を示します。

Ctrl+VK_F12
Ctrl+Shift+VK_A
Alt+Ctrl+VK_SNAPSHOT

Ctrl+Alt+VK_DELETE などの一部のショートカットキーは、システムによって使用されているため、意図したとおりにアプリケーションを起動しない場合があります。補助キーを使用することなくショートカット キーを指定するときは、ユーザーのコンピュータで設定されているショートカット キーと競合しないように注意してください。たとえば、補助キーを使用することなく VK_A を指定すると、ユーザーが A キーを押すたびにアプリケーションが実行されます。

使用できる仮想キー名は、次のとおりです。
仮想キー名 | 16 進数のキー コード | 物理キー
VK_0 ～ VK_9 | 30-39 | 0 ～ 9
VK_A ～ VK_Z | 41-5A | A ～ Z
VK_NUMPAD0 ～ VK_NUMPAD9 | 60-69 | テンキーの 0 ～ 9
VK_F1 ～ VK_F24 | 70-87 | F1 ～ F24 (ファンクション キー)
VK_LBUTTON | 1 | 左マウス ボタン
VK_RBUTTON | 2 | 右マウス ボタン
VK_CANCEL | 3 | コントロール ブレーク処理
VK_MBUTTON | 4 | 中マウス ボタン (3 ボタン マウス)
VK_BACK | 8 | Backspace
VK_CLEAR | 0C | Clear
VK_RETURN | 0D | Enter
VK_PAUSE | 13 | Pause
VK_CAPITAL | 14 | Caps Lock
VK_PRIOR | 21 | PageUp
VK_NEXT | 22 | PageDown
VK_END | 23 | End
VK_HOME | 24 | Home
VK_LEFT 25 ←
VK_UP 26 ↑
VK_RIGHT 27 →
VK_DOWN 28 ↓
VK_SELECT | 29 | Select
VK_EXECUTE | 2B | Execute
VK_SNAPSHOT | 2C | PrintScreen
VK_INSERT | 2D | Ins
VK_HELP | 2F | Help
VK_MULTIPLY | 6A | テンキーのアスタリスク (*)
VK_ADD | 6B | テンキーの正符号 (+)
VK_SEPARATOR | 6C | テンキーのコンマ (,)
VK_SUBTRACT | 6D | テンキーの負符号 (-)
VK_DECIMAL | 6E | テンキーのピリオド (.)
VK_DIVIDE | 6F | テンキーのスラッシュ (/)
VK_NUMLOCK | 90 | Num Lock
VK_SCROLL | 91 | Scroll Lock
実行時の大きさ - アプリケーションまたはファイルを起動するときのウィンドウの種類を、[通常のウィンドウ]、[最小化]、または [最大化] で指定します。
アイコンの変更 - ショートカット用の別のアイコンを選択します。