Office 自訂工具說明檔案

您也可以在 Microsoft Office System 2007 Resource Kit 的 2007 Office 系統中的 Office 自訂工具中，線上找到這個 [說明] 檔案的資訊。

歡迎 |
安裝程式 |
安裝位置與組織名稱 |
其他網路資源 | 新增/修改網路伺服器項目對話方塊
授權與使用者介面 |
移除先前的安裝 |
新增安裝與執行程式 | 新增/修改程式項目對話方塊
Office 安全性設定 |
修改安裝程式內容 | 新增/修改屬性值對話方塊
功能 |
修改使用者設定 |
設定功能安裝狀態 |
檔案與登錄項目 |
新增檔案 | 檔案目的路徑對話方塊
移除檔案 | 檔案路徑對話方塊
新增登錄項目 | 新增/修改登錄項目對話方塊
移除登錄項目 |
設定捷徑 | 新增/修改捷徑項目對話方塊
Outlook |
Outlook 設定檔 |
指定 Exchange 設定 |
新增帳戶 | 新增帳戶對話方塊
移除帳戶與匯出設定 |
指定傳送/接收群組 | 新增 Exchange 群組對話方塊
 | 修改群組對話方塊
 | 重新命名 Exchange 群組對話方塊


Office 自訂工具

使用「Office 自訂工具」(OCT) 可自訂 2007 Microsoft Office system的安裝，您可以在命令列上輸入 setup.exe /admin 來執行 OCT。

當您執行 OCT 時，您可以選擇是要建立新的安裝程式自訂檔案，或是選擇開啟現有的檔案。如果您選擇建立新的檔案，OCT 會顯示網路安裝點上可用的產品清單。您必須選取您想要自訂的單一產品。

附註 2007 Office 版本 需要在所有執行 Office 的電腦 (包括您用來執行 OCT 的電腦) 上安裝 3.1 版或更新版本的 Windows Installer。如需 Windows Installer 3.1 的詳細資訊，包括應該到何處取得它，請參閱 Microsoft 知識庫文章 893803。

使用 OCT 可讓您自訂 Office 並將自訂作業儲存在安裝程式自訂檔案 (MSP 檔) 中，然後將此檔案放在網路安裝點上的 Updates 資料夾中。當您安裝 Office 時，安裝程式會在此 Updates 資料夾中尋找安裝程式自訂檔案，而如果找到的話，則會套用這些自訂作業。如果您將該自訂檔案放在 Updates 資料夾以外的地方，您可以使用安裝程式命令列選項 /adminfile 來指定該檔案的完整路徑，例如 setup.exe /adminfile \\server\share\mychanges\custom.msp。

附註 如果您針對自訂檔案使用 Updates 以外的資料夾，您可以使用 SetupUpdates 元素的 SUpdateLocation 屬性，在 config.xml 檔案中指定該資料夾的位置。如需詳細資訊，請參閱 2007 Microsoft Office 資源套件中＜2007 Office system 的 Config.xml 檔案＞。

您也可以使用安裝程式自訂檔案來變更現有的安裝。由於安裝程式自訂檔案是擴充形式的 Windows Installer MSP 檔案 (副檔名為 .msp)，所以您會將該自訂檔案套用到使用者的電腦，就像是套用軟體更新一樣，而且將會以自訂作業來更新使用者的現有 Office 安裝。例如，如果您將某些功能的安裝狀態變更為 [無法使用]，然後將產生的自訂檔案套用到現有的 Office 安裝，將會從使用者的電腦移除這些功能。

然而，OCT 中有某些選項僅適用於新的 Office 安裝，這些選項會在 OCT 及 OCT 說明檔中加以識別。例如，您可以使用 INSTALLLOCATION 元素來指定 Office 安裝在使用者電腦上的資料夾；但是，如果將自訂檔案套用到現有的安裝，則會忽略此 INSTALLLOCATION 元素 (您將需要解除安裝並重新安裝 Office，才能變更安裝位置)。

選取 [檔案] 功能表上的 [儲存] 可先儲存安裝程式自訂檔案，然後再結束 OCT。

OCT 是由四個主要區段所組成，每一個區段又分為許多含有可自訂之選項的頁面。

  • 安裝程式 - 指定預設的組織名稱、安裝位置及其他安裝來源、設定產品金鑰、接受授權合約、設定顯示層級、選擇所要移除的舊版 Office、定義安裝期間所要執行的自訂程式、自訂 Office 安全性設定，以及設定安裝程式內容。
  • 功能 - 設定預設的使用者選項及選擇所要安裝的功能。
  • 其他內容 - 新增或移除自訂檔案、登錄項目及捷徑。
  • Outlook - 自訂預設的 Microsoft Office Outlook 2007 設定檔並設定 Office Outlook 2007 以及 Microsoft Exchange 2007 選項。


安裝位置與組織名稱

針對安裝作業包含此安裝程式自訂檔案的所有使用者指定預設的組織名稱和安裝位置。

預設安裝路徑 - 這個選項會指定安裝程式將 Office 安裝在使用者電腦上的位置。您可以使用預先定義的資料夾關鍵字 [ProgramFilesFolder] 來指定 Microsoft Windows 中標準資料夾的路徑，預設路徑為 [ProgramFilesFolder]\Microsoft Office。只有當您第一次將 Office 安裝在使用者電腦上時，才會識別這個選項。您必須要先解除安裝並重新安裝 Office，才可以變更安裝路徑。
組織名稱 - 這個名稱會出現在 [說明] 功能表上的 [關於] 方塊中及 Office 應用程式的資訊頁面上。只要使用者的安裝作業包括此自訂檔案，您所指定的名稱就會當做所有這些使用者的預設公司名稱。


其他網路來源

指定具有網路安裝點複本的其他伺服器。

如果安裝程式正在安裝需要的功能或修復 Office，而且無法使用原始的網路安裝點，則安裝程式會依指定的順序在此清單中尋找伺服器。

若要將來源新增至清單，請按一下 [新增]。若要編輯路徑，請從清單中選取伺服器，然後按一下 [修改]。若要從此清單中移除伺服器，請選取該伺服器，然後按一下 [移除]。若要變更此清單的順序，請選取伺服器，然後按一下 [移動] 箭號，在清單中將此伺服器上移或下移。

附註 當您在此清單中新增伺服器時，OCT 不會驗證該伺服器的路徑或嘗試連接該伺服器。


新增/修改網路伺服器項目對話方塊

在 [新增/修改網路伺服器項目] 對話方塊中，輸入網路伺服器的路徑，然後按一下 [確定]。

您可以使用 UNC 路徑，或者當所有使用者都可以存取具有相同磁碟機代號的伺服器時，也可以在路徑中使用磁碟機代號。此路徑可以包含以百分比符號 (%) 所分隔的環境變數 (如果這些變數是針對所有使用者所定義)。

例如：

z:\office
\\server1\share\office_root
%USERNAME%\office_root


授權及使用者介面

代表使用此安裝程式自訂檔案來安裝 Office 的每一位使用者輸入產品金鑰及接受使用者授權合約 (EULA)，並且設定使用者介面的顯示層級。只有當您第一次將 Office 安裝到使用者電腦上時，安裝程式才會識別這些選項。

產品金鑰 - 輸入有效的大量授權金鑰 (25 個字元)。
我接受授權合約 - 選取此核取方塊即會代表使用者接受授權合約的條款。如果 [顯示層級] 設為 [基本] 或 [無]，而且您有提供產品金鑰，則安裝程式會假設您也代表使用者接受此授權合約。在此情況下，即使您未設定此核取方塊，系統還是不會在安裝期間或第一次執行 Office 應用程式時，提示使用者接受授權合約。
顯示層級 - 選取在安裝期間顯示使用者介面的方式。選項包括：
  1. 完整 - 預設 - 安裝程式會以互動方式執行，顯示所有的使用者介面和訊息。
  2. 基本 - 安裝程式會顯示歡迎畫面、提示您輸入產品金鑰及接受使用者授權合約 (如有需要)，並顯示進度列和完成通知。
  3. 無 - 安裝程式會以無訊息模式執行，不顯示任何使用者介面。
完成通知 - 如果您希望安裝程式在安裝完成時對使用者顯示一則訊息，請選取此核取方塊。
隱藏強制回應 - 如果您不希望安裝程式顯示錯誤訊息及其他可能會中斷安裝作業的對話方塊，請選取此核取方塊。如果您將 [顯示層級] 設為 [完整]，則不論此核取方塊的狀態為何，都會顯示錯誤訊息和其他對話方塊。

附註 以上的選項與 Config.xml 檔中的以下設定相同：

OCT 選項 | Config.xml 設定
產品金鑰 | PIDKEY 元素
我接受...授權合約 | Display 元素的 AcceptEula 屬性
顯示層級 | Display 元素的 Level 屬性
完成通知 | Display 元素的 CompletionNotice 屬性
隱藏強制回應 | Display 元素的 SuppressModal 屬性


移除先前的安裝

指定要保留或移除的舊版 Microsoft Office 應用程式。只有當您第一次將 Office 安裝到使用者電腦上時，安裝程式才會識別這個選項。

根據預設，安裝程式會移除所有舊版的 Office 應用程式。若要保留已安裝的 Office 應用程式，請選取 [移除下列舊版的 Microsoft Office 程式]，並選取您不想要移除的 Office 應用程式，然後按一下 [詳細資料]，再清除此核取方塊。

附註 Office Outlook 2007 無法和舊版 Outlook 並存。如果您選擇要保留舊版 Outlook，請勿安裝 Office Outlook 2007。


新增安裝並執行程式

在 Office 安裝完成前或完成後執行其他可執行程式。

安裝程式會根據所列的順序執行所有命令列，而且要等到所有命令列都已執行之後，才會完成安裝。

附註 請勿加入需要重新啟動電腦的程式，除非該程式為清單中的最後一個程式。如果自訂的程式會重新啟動電腦，則 Office 安裝將會完成，但是將不會執行此清單中順序在後面的任何自訂程式。

若要在此清單中加入程式，請按一下 [新增]。若要修改程式，請選取該程式，然後按一下 [修改]。若要移除程式，請選取該程式，然後按一下 [移除]。若要變更此清單的順序，請選取程式，然後按一下 [移動] 箭號，在清單中將此程式上移或下移。


新增/修改程式項目對話方塊

當您新增或修改程式項目時，可以在 [新增/修改程式項目] 對話方塊中輸入下列資訊，然後按一下 [確定]。

目標 - 輸入可執行程式的路徑和檔案名稱。
引數 - 輸入命令列選項字串，例如 /q /path c:\temp。
安裝 Office 產品之後執行此程式 - 在 Office 安裝完成之後執行程式。這是建議選項。如果程式未正常終止，或造成電腦重新啟動，Office 安裝不會受到影響。不過，清單中排在後面的程式都不會執行。
安裝 Office 產品之前執行此程式 - 在開始安裝 Office 之前執行程式。如果程式未正常終止，或造成電腦重新啟動，則 Office 不會安裝，清單中排在後面的程式也不會執行。

在 [新增/修改程式項目] 對話方塊中，您可以將下列標準 Windows 資料夾包含在可執行檔的路徑中。

[SourceDir] | 用來安裝 Office 的網路安裝點根目錄
[INSTALLLOCATION] | 安裝 Office 的資料夾
[WindowsFolder] | Windows 資料夾
[SystemFolder] | Windows System32 資料夾
[ProgramFilesFolder] | Program Files 資料夾
[CommonFilesFolder] | Program Files\Common Files 資料夾
[DesktopFolder] | Windows [桌面] 資料夾
[StartMenuFolder] | Windows [開始] 功能表
[ProgramMenuFolder] | Windows [開始]\[程式集] 功能表


修改安裝程式內容

設定在 Office 安裝期間所要套用的屬性。只有當您第一次將 Office 安裝在使用者電腦上時，才可以自訂安裝程式內容；如果您將自訂檔案套用到現有的安裝，則這個檔案中所設定的屬性將不會生效。

若要新增屬性，請按一下 [新增]。若要修改您已新增的屬性，請選取該屬性，然後按一下 [修改]。若要移除您已新增的屬性，請選取該屬性，然後按一下 [移除]。

如需屬性及屬性值的詳細資訊，請參閱＜2007 Office 系統中的安裝程式內容＞(英文)。


新增/修改屬性值對話方塊

當您新增或修改安裝程式內容時，請在 [新增/修改屬性值] 對話方塊中輸入下列資訊，然後按一下 [確定]：

名稱 - 屬性名稱。屬性名稱必須全字大寫。
值 - 屬性的值。


修改使用者設定

針對使用這個自訂檔案安裝 Office 的使用者設定 Office 應用程式設定的預設值。

若要設定選項，請展開左邊的樹狀結構，然後按一下使用者介面元素；與該元素有關之所有可設定的設定值都會出現在右邊。按兩下某個設定值，然後選取下列其中一個選項：

尚未設定 - 將此設定保留原狀。
啟用 - 根據對話方塊中的選項來修改此設定。
停用 - 停用此設定。請注意，停用選項與未設定選項並不相同。如需詳細資料，請參閱特定選項的描述。

按一下 [顯示所有設定] 可顯示所有可用的使用者設定。按一下 [只顯示已設定的設定] 可以只顯示已設定的設定。

選取 [移轉使用者設定] 核取方塊可保留舊版 Office 中的使用者自訂設定。如果您修改使用者設定，而且也選取此核取方塊，則安裝程式會先套用修改過的設定，然後移轉使用者現有的自訂設定，覆寫任何衝突的設定。

附註 當您按一下 [啟用] 以檢視設定的選項，然後按一下 [確定]，或是 [上一個設定] 或 [下一個設定] 時，其狀態會變為 [已設定]，即使您未變更此設定也是一樣。如果您不慎使用空的超連結、路徑或檔案名稱進行此設定，則會發生錯誤。如果您按一下 [啟用] 而且想要忽略變更或避免進行此設定時，請按一下 [取消]。您也可以將設定返回 [尚未設定] 狀態，只需要按兩下該設定，然後選取 [尚未設定]，再按一下 [確定] 即可。


設定功能安裝狀態

自訂在使用者電腦上安裝 Office 功能的方式。

若要變更某項功能的安裝狀態，請選取該項功能，然後選取安裝狀態。某些功能 (稱為父功能) 是由多個子功能所組成；若要檢視子功能，請按一下父功能左邊的加號 (+) 來展開。

當您變更某項功能的安裝狀態時，該項功能的名稱及它的所有子功能名稱 (如果有的話) 都會以粗體字型顯示，表示安裝程式會將這些變更套用到安裝；不是以粗體字型顯示的功能則會使用預設安裝狀態進行安裝。如果您想要移除所做的變更，請選取該項功能，然後選取 [重設] 選項，或按一下 [重設子目錄]。

以下功能安裝狀態通常會在安裝期間提供給使用者使用，並非每一項功能都可以使用所有安裝狀態。例如，如果某項功能包含無法通告的元件，則該功能的可用安裝狀態清單中將不會包含 [第一次使用時才安裝]。

從我的電腦執行 | 安裝程式會將與此功能有關的檔案及登錄項目和捷徑複製及寫入到使用者的硬碟上，而且應用程式或功能會在本機執行。
全部從我的電腦執行 | 與 [從我的電腦執行] 相同，唯一不同的是屬於此功能的所有子功能也會設為這個狀態。
第一次使用時才安裝 | 安裝程式會將此功能的元件及它的所有子功能保留在安裝來源中，直到使用者第一次嘗試使用此功能為止，此時會將這些元件複製到本機硬碟上。這也稱為通告功能。
無法使用 | 此功能的元件及屬於此功能的所有子功能都不會安裝在電腦上。

每一項功能還可以使用下列選項。

隱藏 | 如果安裝程式以互動方式執行，則不會在安裝期間於功能樹狀結構中顯示此功能。當 Office 安裝之後在維護模式中執行安裝程式時，將不會隱藏此功能。[H] 符號會加到功能名稱開頭，表示隱藏此功能。
鎖定 | 在安裝期間或是 Office 安裝之後的維護模式中，使用者無法變更您為這項功能選擇的安裝狀態。[L] 符號會加到功能名稱開頭，表示鎖定此功能。
重設 | 此功能會返回其預設安裝狀態。這與選取功能後再按一下 [重設子目錄] 按鈕是一樣的。

如果明確地將功能設定為其預設狀態，[F] 符號會加到功能名稱開頭，表示此功能將強制進入此狀態。如果您要建立安裝程式自訂檔案來修改現有的 Office 安裝，這麼做很有幫助 - 如果您不變更功能的安裝狀態，則安裝程式也不會在使用者的電腦上變更功能；但如果您指定變更，甚至是將功能設定為其正常預設狀態，安裝程式仍可確定功能會設定為使用者電腦上的該狀態。

當您變更某項功能的安裝狀態時，安裝程式可相對應地變更父功能或子功能的安裝狀態。例如，如果您將父功能設為 [第一次使用時才安裝]，但是將子功能設為 [從我的電腦執行]，則安裝程式也會將此父功能的狀態設為 [從我的電腦執行]。

當使用者以互動方式執行安裝程式時，安裝程式不會在功能樹狀結構中顯示隱藏的功能，而會根據其已定義的安裝狀態安裝此功能。屬於該隱藏功能的所有子功能也會隱藏起來。

顯示 秘訣

[隱藏] 設定的最佳用途是為使用者簡化功能樹狀結構。例如，您可以隱藏功能樹狀結構的 Office 工具子目錄，好讓使用者不必決定所需的工具；只會安裝您所選取的工具。

如果您將某項功能設為 [無法使用]，並在功能樹狀結構中隱藏該項功能，則使用者只要藉由安裝父功能或是在維護模式中執行安裝程式，仍然可以變更設定並安裝該項功能。例如，如果您將 [名稱智慧標籤外掛程式] 功能設為 [無法使用] 和 [隱藏]，使用者仍然可以藉由將父功能 [名稱智慧標籤外掛程式] 設為 [全部從我的電腦執行] 來安裝此項功能。如果您想要防止使用者安裝隱藏的功能，請選取 [無法使用]、[隱藏] 和 [鎖定] 安裝狀態。在此情況下，該功能或應用程式將不會安裝，也無法在維護模式中使用。使用者無法藉由變更其父功能的狀態來安裝該功能。在 Office 安裝之後，若要回復 [無法使用]、[隱藏] 和 [鎖定] 安裝狀態，唯一的方法就是使用 OCT 來建立安裝程式自訂檔案，設定此檔案來變更此功能的安裝狀態，然後將此自訂檔案套用到使用者的電腦。


新增檔案

在安裝 Office 時新增檔案至使用者的電腦。

若要建立在安裝期間要新增至使用者電腦的檔案清單，請按一下 [新增]，選取您要新增至清單中的檔案，然後再次按一下 [新增]。若要變更檔案的目的路徑，請在 [新增自訂檔案] 清單中選取檔案，然後按一下 [修改]。若要從此清單中移除檔案，請選取該檔案，然後按一下 [移除]。您可以使用 SHIFT 和 CTRL 鍵，一次選取多個檔案。

新增檔案至 Office 安裝時，請注意以下事項：

  • 當您儲存安裝程式自訂檔案及結束 OCT 時，檔案會複製到此自訂檔案中。大型檔案會讓此自訂檔案增大，並增加建立此檔案所需的時間。
  • 如果您要修改目前包含在此自訂檔案中的檔案，必須使用 OCT 開啟此自訂檔案、從 [新增檔案] 清單中移除該檔案、新增修改過的版本，然後儲存此自訂檔案。
  • 如果使用者移除、修復或重新安裝 Office，則自訂檔案會連同 Office 一起移除或重新安裝。但是，如果自訂檔案在安裝之後已經有變動，則安裝程式將不會重新安裝該檔案。


檔案目的路徑對話方塊

在 [使用者電腦上的目的路徑] 對話方塊中，輸入您希望在使用者電腦上安裝此檔案的資料夾，然後按一下 確定。

您可以使用 SHIFT 和 CTRL 鍵，一次選取多個檔案；這些檔案會與相同的目的資料夾產生關聯。您可以在目的路徑中使用下列特殊資料夾名稱：

[INSTALLLOCATION] | 安裝 Office 的資料夾
[ROOTDRIVE] | 含有最大可用空間的本機磁碟機
[ProgramFilesFolder] | Program Files 資料夾
[CommonFilesFolder] | Program Files\Common Files 資料夾
[WindowsFolder] | Windows 資料夾
[SystemFolder] | Windows System32 資料夾
[PersonalFolder] | 使用者的 [我的文件] 資料夾
[AppDataFolder] | 使用者的 Application Data 資料夾
[NetHoodFolder] | 使用者的 [網路上的芳鄰] 資料夾


移除檔案

在安裝 Office 時，從使用者的電腦移除檔案。

若要建立在安裝期要從使用者電腦中移除的檔案清單，請按一下 [新增]。若要修改檔案的路徑或名稱，請在 [移除檔案] 清單中選取檔案，然後按一下 [修改]。若要從此清單中移除檔案，請選取該檔案，然後按一下 [移除]。您可以使用 SHIFT 和 CTRL 鍵，一次選取多個檔案。

附註 在安裝 [新增檔案] 清單中所列的檔案之前，會從使用者電腦中移除 [移除檔案] 清單中所列的檔案。如此，您就可以刪除使用者電腦上的現有檔案，然後以新的版本來取代。如果使用者電腦上的目標檔案已重新命名或修改過，則所新增的同名檔案將不會取代該檔案。


檔案路徑對話方塊

在 [檔案路徑] 對話方塊中，輸入您想要加入至要從使用者電腦中移除之檔案清單中的檔案路徑和檔案名稱，然後按一下 [確定]。

該路徑必須以磁碟機代號當做開頭，或者必須是 UNC 路徑或下列其中一個特殊資料夾：

[INSTALLLOCATION] | 安裝 Office 的資料夾
[ROOTDRIVE] | 含有最大可用空間的本機磁碟機
[ProgramFilesFolder] | Program Files 資料夾
[CommonFilesFolder] | Program Files\Common Files 資料夾
[WindowsFolder] | Windows 資料夾
[SystemFolder] | Windows System32 資料夾
[PersonalFolder] | 使用者的 [我的文件] 資料夾
[AppDataFolder] | 使用者的 Application Data 資料夾
[NetHoodFolder] | 使用者的 [網路上的芳鄰] 資料夾


新增登錄項目

在安裝 Office 時，於使用者的電腦上新增或修改登錄項目。

若要建立要新增至使用者電腦的登錄項目清單，請按一下 [新增]。若要變更清單中的項目，請選取該項目，然後按一下 [修改]。若要從此清單中移除項目，請選取該項目，然後按一下 [移除]。按一下 [匯入] 可從登錄檔案 (REG 檔案) 中新增一組項目。如果該 REG 檔中的項目與此清單中的項目重複，則 OCT 會提示您選擇是否要使用此 REG 檔中的登錄項目來覆寫現有的登錄項目。

附註 在此區段中所自訂的登錄項目可覆寫 OCT 中其他位置所自訂的設定。使用此區段可自訂無法直接在 Office 使用者介面中設定的選項，以及無法使用 OCT 中其他方法來設定的選項。


新增/修改登錄項目對話方塊

在 [新增/修改登錄項目] 對話方塊中，針對每一個登錄項目輸入下列資訊，然後按一下 [確定]：

根目錄 - 選取包含您要新增或修改之項目的分支。每個使用者 (HKEY_CURRENT_USER) 或每一台電腦 (HKEY_LOCAL_MACHINE) 分別會套用一次設定。請注意，您不能將任何登錄項目新增到 HKEY_USERS 或 HKEY_LOCAL_MACHINE 的根目錄。
資料類型 - 選取登錄值的資料類型。
機碼 - 輸入用來儲存該項目的子機碼名稱，例如 Software\Microsoft\Office\12.0\Common。
建立空的機碼 - 如果登錄機碼沒有包含資料名稱或資料值，請選取這個核取方塊。部分設定是由登錄機碼是否存在決定。
數值名稱 - 輸入新登錄項目的名稱。如果您加入 [數值資料]，但卻將這個欄位留白，系統便會將數值名稱指定為 <Default>。一個機碼只能有一個 <Default> 數值名稱。
數值資料 - 輸入要儲存在新登錄項目中的資料 (值)。此資料必須與資料類型相符。


移除登錄項目

在安裝 Office 時，從使用者的電腦移除登錄項目。

若要建立要從使用者電腦中移除的登錄項目清單，請按一下 [新增]，然後針對每一個登錄項目輸入下列資訊：

根目錄 - 選取包含您要移除之項目的分支。
機碼 - 輸入用來儲存該項目的完整子機碼名稱，例如 Software\Microsoft\Office\12.0\Common。
數值名稱 - 輸入您想要移除的登錄項目名稱。若要移除整個子機碼，包括它的所有數值項目，請將此欄位留白。

附註 如果使用者移除、修復或重新安裝 Office，則自訂登錄項目會連同 Office 一起移除或重新安裝。


刪除/修改登錄項目對話方塊

在 [刪除/修改登錄項目] 對話方塊中，針對每一個登錄項目輸入下列資訊，然後按一下 [確定]：

根目錄 - 選取包含您要移除之項目的分支。
機碼 - 輸入用來儲存該項目的子機碼名稱，例如 Software\Microsoft\Office\12.0\Common。
數值名稱 - 輸入您想要移除的登錄項目名稱。若要移除整個子機碼，包括它的所有數值項目，請將此欄位留白。


Outlook 設定檔

自訂使用者的預設 Outlook 設定檔，此設定檔為 Windows 登錄中用來定義使用者特定資訊的一組值。Outlook 設定檔可包含多個電子郵件帳戶，使用者可以擁有多個 Outlook 設定檔，但是在安裝程式自訂檔案中只能設定一個設定檔。

使用現有的設定檔 - 使用已在使用者電腦上設定的設定檔，或是提示使用者在第一次啟動 Outlook 時建立設定檔。選擇這個選項會停用 OCT 的其他 Outlook 區段。
修改設定檔 - 修改使用者電腦上的預設設定檔，或是使用您指定的名稱來定義設定檔的變更。如果沒有任何預設設定檔或是沒有您指定之名稱的設定檔存在，則 Outlook 會根據您在 OCT 的其他 Outlook 區段中所選擇的選項來建立設定檔。Outlook 會使用預設設定檔名稱 (Outlook) 或使用您已指定的設定檔名稱。
新增設定檔 - 在使用者電腦上建立新的設定檔，並將它設為預設設定檔；系統不會移除任何現有的設定檔，使用者仍然可以使用這些設定檔。您必須在 [設定檔名稱] 方塊中輸入名稱，這個名稱會出現在 Outlook 的 [電子郵件帳戶] 對話方塊中。Outlook 會根據您在 OCT 的其他 Outlook 區段中所選擇的選項來建立設定檔。
套用 PRF - 匯入 Outlook 設定檔 (PRF 檔案) 可定義新的預設設定檔。選取這個選項會停用 OCT 的其他 Outlook 區段，但是不會以 PRF 檔案中的設定來更新 OCT。您可以使用針對 Office Outlook 2007 建立的任何設定檔。請在 [套用下列設定檔 (PRF 檔案)] 方塊中輸入設定檔的名稱和路徑。如果您已經針對舊版 Outlook 建立 PRF 檔案，則可以將它匯入到 Office Outlook 2007，但前提是該設定檔只能定義 MAPI 服務。

如果您將 Office 安裝在使用者沒有系統管理權限且已鎖定的電腦上，則使用者在安裝 Office 之後將無法設定其 Outlook 設定檔。


指定 Exchange 設定

在新的或修改過的 Outlook 設定檔中設定使用者的 Microsoft Exchange 設定。

Exchange Server 連線

為新的或現有的設定檔設定 Exchange Server 連線。

不設定 Exchange Server 連線 - 在 Outlook 第一次啟動時，提示使用者輸入設定檔及帳戶資訊 (除非電腦上已經有設定檔存在)。
設定 Exchange Server 連線 - 設定新 Exchange Server 連線的設定，或是取代現有 Exchange Server 連線中的設定。請輸入下列資訊：
  • 使用者名稱 - 以特定的值或可取代的參數識別使用者。如果您指定預設的 %USERNAME%，則在 Outlook 啟動時，Outlook 會使用使用者的精確登入名稱，而不是提示使用者可能的變化形式。
  • Exchange Server - 輸入當使用者啟動 Outlook 時，可能使用的 Exchange Server 名稱。當使用者第一次啟動 Outlook 時，Outlook 會以使用者的正確 Exchange Server 來取代這個值。這個文字方塊中只會提供一個常值伺服器名稱，例如 Exch-2-Srvr。請勿包含反斜線 (\\) 或類似語法。
  • 若存在 Exchange 連線則覆寫現有的 Exchange 設定 - 選取這個選項可使用這個帳戶來取代使用者設定檔中現有的 Exchange Server 帳戶。

快取 Exchange 模式

使用下列選項可設定使用者的 Outlook 設定檔來使用 Exchange 信箱的本機複本。

不設定快取 Exchange 模式 - 根據預設，Exchange 信箱可從 Exchange Server 中存取，而不用在使用者電腦上快取「離線存放區檔案」(OST 檔案)。
設定快取 Exchange 模式 - 建立 OST 檔案或使用現有的 OST 檔案；使用者會使用其 Exchange 信箱的本機複本。如果您選取 [使用快取 Exchange 模式]，則可以使用下列選項為使用者設定快取 Exchange 模式。
僅下載標題 - 只會從使用者的 Exchange 信箱下載標題複本。
先下載標題再完整項目 - 從使用者的 Exchange 信箱下載標題複本，然後再下載郵件複本。
下載完整項目 - 從使用者的 Exchange 信箱下載完整郵件複本 (標題和郵件本文)。
慢速連線時僅下載標題 - 當偵測到慢速網路連線時，只會從使用者的 Exchange 信箱下載標題複本。
下載共用非郵件資料夾 - 下載任何共用非郵件資料夾。
下載我的最愛公用資料夾 - 下載 [我的最愛公用資料夾] 的清單。


其他 Exchange Server 設定

設定 Exchange Server 離線使用選項及「Outlook 無所不在」功能。如需設定這些設定的完整資訊，請參閱 2007 Microsoft Office Resource Kit 中的《Configuring Cached Exchange Mode with Outlook 2007》。


新增帳戶

在使用者的設定檔中包含新的 Outlook 電子郵件帳戶。

如果您不想將帳戶新增至新的或修改過的 Outlook 設定檔中，請選取 [不自訂 Outlook 設定檔與帳戶資訊] 選項。

若要在新的或修改過的 Outlook 設定檔中指定新的帳戶資訊，請選取 [自訂其他 Outlook 設定檔與帳戶資訊] 選項。當使用者第一次啟動應用程式時，Outlook 會根據您指定的資訊建立設定檔。

若要在此清單中新增帳戶，請按一下 [新增]。若要修改清單中的帳戶，請選取該帳戶，然後按一下 [修改]。若要從此清單中移除帳戶，請選取該帳戶，然後按一下 [移除]。

您也可以指定下列各項：

  • 傳送新郵件至下列位置 - 當您設定 Exchange Server 或新增個人資料夾檔案 (PST 檔案) 時，選取這個選項可指定新電子郵件的傳送位置。預設位置為 Exchange Server (如果已設定)，否則此位置會預設為使用者電腦上的 PST 檔案。
  • 預設電子郵件帳戶 - 選取要設為使用者之預設電子郵件帳戶的帳戶。


新增帳戶和帳戶設定對話方塊

如果您要新增帳戶，請選取要新增的帳戶類型，然後按一下 [下一步]。

在 [<account type> 設定] 對話方塊中，設定適合您要新增或修改之帳戶類型的選項，如帳戶名稱、使用者名稱、郵件伺服器和電子郵件地址。如需其他設定選項，請按一下 [其他設定]。當您完成時，請按一下 [完成]。

為了確保電子郵件服務不會出現重複的狀況，Outlook 可能不允許您針對同一種服務新增多個帳戶。例如，Outlook 會確認所有的 POP 帳戶都有唯一的名稱。下表顯示當新帳戶的類型與現有帳戶相同時，Outlook 決定新帳戶是否可以新增到安裝自訂檔案的標準。

帳戶類型 | 新增重複的帳戶？ | 用來判斷是否有衝突存在的資料
POP3 | 否 | 帳戶名稱
IMAP | 否 | 帳戶名稱
Hotmail 或 HTTP | 否 | 帳戶名稱
PST | 否 | PST 檔案的名稱和路徑
Unicode PST | 否 | Unicode PST 檔案的名稱和路徑
Outlook 通訊錄 | 是 | 帳戶是否存在
個人通訊錄 | 是 | 帳戶是否存在
LDAP | 否 | 帳戶名稱
Exchange | 是 | 提供者是否存在


移除帳戶及匯出設定

移除現有的電子郵件帳戶，或是將設定匯出到 PRF 檔案。

只有當您選取 OCT 的 [Outlook 設定檔] 頁面上的 [修改設定檔] 時，才可使用這個選項來移除帳戶。在 [下列帳戶存在時，予以移除] 底下，選取 [Lotus cc:Mail] 或 [Microsoft Mail]，即可在 Outlook 第一次啟動時從使用者電腦中移除這些帳戶。

按一下 [匯出設定檔設定] 按鈕可儲存您已經在 PRF 檔案中定義的 Outlook 設定檔設定。

顯示 秘訣

有一個很有效率的方法可以用來建立 Outlook PRF 檔案，就是使用 OCT 來進行選擇，並將選擇結果匯出到 PRF 檔案，即使當您在部署 Office 時未使用安裝程式自訂檔案，也同樣可行。您可以編輯此 PRF 檔案，以進行 OCT 中未公開的其他自訂作業。例如，您可以新增未列於 OCT 中的電子郵件提供者。


指定傳送/接收群組

為 Exchange 帳戶和資料夾定義傳送/接收群組，並指定在 Outlook 中的傳送/接收期間於每一個群組上執行的工作。傳送/接收群組包含 Outlook 帳戶和資料夾的集合；您可以在 Outlook 連線和離線時，為傳送/接收群組指定不同的選項。

不設定傳送/接收設定 - 不設定傳送/接收群組的設定；只會以 [所有帳戶] 群組和它的預設設定來設定 Outlook (如果使用者已建立其他群組，當使用者升級到 Office Outlook 2007 時，這些群組也會移轉)。
設定傳送/接收設定 - 設定傳送/接收群組的設定 (僅限 Exchange 帳戶和資料夾)。
  • 按一下 [新增] 可建立一組新的帳戶和資料夾。
  • 按一下 [修改] 可指定或重新定義傳送/接收群組的選項。
  • 按一下 [重新命名] 可變更現有傳送/接收群組的名稱。
  • 按一下 [移除] 可移除現有的傳送/接收群組。

已選取之群組的傳送/接收設定

針對清單中所選的傳送/接收群組指定設定 (選定之群組的名稱會出現在選項標籤中)。您可以在 Outlook 連線或離線時指定不同的設定。

當 Outlook 在線上
  • 將這個群組加入傳送/接收 - 當使用者按一下 [傳送/接收] 時，在這個群組上執行 [傳送/接收] 動作。
  • 排定自動傳送/接收每隔 n 分鐘 - 選擇每個 [傳送/接收] 動作間的間隔。
  • 結束時自動執行傳送/接收 - 當使用者結束 Outlook 時，自動執行這個群組的 [傳送/接收] 動作。
當 Outlook 離線時
  • 將這個群組加入傳送/接收 - 當使用者按一下 [傳送/接收] 時，在這個群組上執行 [傳送/接收] 動作。
  • 排定自動傳送/接收每隔 n 分鐘 - 選擇每個 [傳送/接收] 動作間的間隔。
Exchange 通訊錄
  • 下載離線通訊錄 - 當使用者按一下 [傳送/接收] 時，下載離線通訊錄。
  • 按一下 [通訊錄設定] 可開啟 [修改通訊錄設定] 對話方塊。您可以選取 [下載自上次傳送/接收後的變更]，只下載上一次下載之後的通訊錄更新，您也可以選擇是要下載 [完整詳細資料] 還是 [不含詳細資料]。


新增 Exchange 群組對話方塊

在 [新增群組名稱] 方塊中輸入您要建立的 Exchange 傳送/接收群組名稱，然後按一下 [確定]。


修改群組對話方塊

當您修改群組時，請從 [修改群組] 對話方塊中選取下列選項，然後按一下 [確定]。

在 [選取這個傳送/接收群組的選項] 底下，選取下列選項：

傳送郵件項目 - 在執行這個群組的 [傳送/接收] 時，從 [寄件匣] 傳送郵件項目。
接收郵件項目 - 在執行這個群組的 [傳送/接收] 時，接收郵件項目。
使資料夾首頁可離線可用 - 在執行這個群組的 [傳送/接收] 時，重新整理資料夾首頁的內容。
同步處理表單 - 在執行這個群組的 [傳送/接收] 時，同步處理表單。

在 [變更這個傳送/接收群組的資料夾選項] 底下選取資料夾，然後提供下列資訊：

將這個資料夾加入傳送/接收 - 將這個資料夾加入要在這個 [傳送/接收] 群組的 [傳送/接收] 期間進行更新的一組資料夾中，然後選取下列選項：
  • 僅下載標題 - 在針對這個 [傳送/接收] 群組執行 [傳送/接收] 來進行更新時，只下載這個資料夾的標題。
  • 下載包括附件的完整項目 - 對這個 [傳送/接收] 群組執行 [傳送/接收] 以進行更新時，下載這個資料夾的所有電子郵件訊息 (或其他項目)。
  • 只下載項目標題，當項目大於 - 當項目大於指定大小時，只下載項目的標題。對這個 [傳送/接收] 群組執行 [傳送/接收] 以進行更新時，這項設定只適用於這個資料夾。


重新命名 Exchange 群組對話方塊

在 [新增群組名稱] 方塊中輸入 Exchange 傳送/接收群組的新名稱，然後按一下 [確定]。


修改通訊錄設定對話方塊

設定 Outlook 將離線通訊錄保持在最新狀態的預設方式。請從下列選項中選取：

下載前次同步處理後所做的變更 – Outlook 只會下載自上次「傳送/接收」作業後對通訊錄所做的變更。這通常會比下載完整通訊錄花費較少的時間。
完整詳細資料 – 下載通訊錄時，Outlook 會複製每個項目的所有詳細資料。
不含詳細資料 – 下載通訊錄時，Outlook 只會複製必要的資訊，例如每個項目的名稱和電子郵件地址。雖然這會花費較少的下載時間，不過離線通訊錄中不會包含地址詳細資料。


Office 安全性設定

自訂 Office 應用程式的安全性設定。

附註 安裝程式自訂檔案中所指定的安全性設定會變成使用者電腦上的預設設定；但是，使用者可以在安裝之後變更這些設定。若要鎖定安全性設定，請使用 [群組原則]。如需詳細資訊，請參閱＜鎖定 2007 Office 系統的電腦＞(英文)。

受信任的發行者 - 管理會識別受信任來源的清單 (指經過數位簽章之巨集、增益集、Microsoft ActiveX 控制項和 Office 應用程式所用之其他可執行碼的受信任來源)。Office 應用程式會與 Internet Explorer 共用憑證的受信任來源清單。按一下 [新增] 可新增數位憑證 (CER 檔案)，新增預設的 Microsoft CER 檔案可確保所有的增益集和範本都會隨 Office 應用程式一起安裝在使用者的電腦上。
信任位置 - 管理會識別位置的清單，這是指可以在不經過 [信任中心] 安全性功能檢查的情況下開啟任何檔案的來源位置。按一下 [新增] 可新增位置，接著輸入下列資訊，然後按一下 [確定]：
應用程式 - 選取使用這個位置的 Office 應用程式。
路徑 - 輸入信任位置的路徑。請輸入包含磁碟機代號的完整路徑或 UNC 路徑，路徑中可包含環境變數。
此位置的子資料夾也受信任 - 選取此核取方塊可加入子資料夾當做信任位置。
描述 - 輸入用來描述此位置之用途的文字。

若要從此清單中移除信任位置，請選取該位置，然後按一下 [移除]。

附註 當您在這裡指定一個或多個信任位置時，會清除之前在使用者電腦上所定義的 [信任位置] 清單，並以這個清單來取代。

移除所有安裝時由 OCT 寫入的信任位置 - 會清除使用者電腦上的 [信任位置] 清單。如果您希望清除使用者電腦上的 [信任位置] 清單且不新增任何位置，請使用此核取方塊。
預設安全性設定 - 設定增益集、範本和 Office 應用程式的預設安全性層級。您可以針對每一個 Office 應用程式設定下列選項：
  • 允許的信任位置選項
    1. 允許不在使用者電腦上的信任位置
    2. 停用所有信任位置，只信任由信任的發行者簽署的檔案
  • 應用程式延伸模組警告選項
    1. 停用所有應用程式延伸模組
    2. 應用程式延伸模組必須經過信任的發行者簽署
    3. 延伸模組必須經過簽署，且會自動停用未簽署的延伸模組
  • VBA 巨集警告選項
    1. 停用所有 VBA 巨集
    2. 停用未簽署之 VBA 巨集的信任列警告 (將停用未簽署的程式碼)
    3. 不對 VBA 巨集執行安全性檢查 (不建議使用，因為所有文件中的程式碼都能執行)
  • 增益集及範本 (僅限 Microsoft Office Project 2007)
    1. 信任所有已安裝的增益集及範本
    2. 不信任已安裝的增益集及範本
  • 安全性層級 (僅限 Office Project 2007)
    1. 高 - 只有來自被信任來源的簽章巨集允許被執行，未經簽章的巨集都會被自動停用
    2. 中 - 您可以選擇是否要執行具有潛在危險性的巨集
    3. 低 (不建議使用) - 對於具有潛在危險性的巨集，您將不會受到保護
不安全的 ActiveX 初始化 - 判斷是否可以使用「持續性資料」(也就是從一個控制項執行個體儲存到下一個控制項執行個體的資料) 初始化未簽署因而具有潛在危險性的 ActiveX 控制項。可能的值如下：
<不設定> - 安裝程式不會修改使用者電腦上所指定的設定，會使用預設設定 ([提示使用者使用持續性資料]) 安裝新的應用程式。
提示使用者使用控制項預設值 - 在應用程式初始化可能不安全的 ActiveX 控制項之前警告使用者。如果使用者信任文件的來源，則會使用控制項的預設設定初始化該控制項。
提示使用者使用持續性資料 - 在應用程式初始化可能不安全的 ActiveX 控制項之前警告使用者。如果使用者信任文件的來源，則會使用持續性資料初始化該控制項。
不提示 - 在不提示使用者的情況下執行所有未簽署的 ActiveX 控制項。這項設定會提供最低的安全保護，所以不建議使用。


設定捷徑

修改或移除所安裝之 Office 應用程式的預設捷徑，以及新增隨 Office 2007 版本 一起安裝或已經在使用者電腦上之任何檔案的捷徑。

若要新增捷徑，請按一下 [新增]。若要修改此清單中的捷徑，請選取該捷徑，然後按一下 [修改]。若要從此清單中移除捷徑，請選取該捷徑，然後按一下 [移除]。

附註 如果您新增自訂應用程式或檔案的捷徑，則當使用者修改、修復、重新安裝或移除 Office 時，將不會更新或移除該捷徑。


新增/修改捷徑項目對話方塊

在 [新增/修改捷徑項目] 對話方塊中，針對您要建立或修改的捷徑輸入下列資訊，然後按一下 [確定]：

目標 - 透過選取預先定義的應用程式關鍵字，或是輸入捷徑所指向的檔案名稱和路徑，指定與捷徑相關的應用程式。如果選取應用程式關鍵字，OCT 會自動在其他方塊中輸入資訊。清單中的名稱會對應於您在 OCT 的 [設定功能安裝狀態] 頁面中選取的功能，以及在 [新增檔案] 頁面上新增到安裝中的任何自訂檔案。如果輸入名稱和路徑，而名稱或路徑中包含空格，則必須將整個字串包含在雙引號 ("") 中。您可以使用下面的 [引數] 欄位新增應用程式的命令列選項。
位置 - 透過選取預先定義的資料夾關鍵字，或輸入指向捷徑位置的名稱和路徑，指定在其中建立捷徑的資料夾。您可以附加反斜線 (\)，後面再接上子資料夾名稱，以指定子資料夾。例如，若要將 Microsoft Office Word 2007 捷徑安裝在 [開始] 功能表內 [程式集] 資料夾中的 [Microsoft Office] 子資料夾中，請選取 [ProgramMenuFolder]，然後加上下列子資料夾名稱：[ProgramMenuFolder]\Microsoft Office。

您可以使用下列特殊資料夾代表 [位置]：

[StartMenuFolder] | Windows [開始] 功能表
[ProgramMenuFolder] | Windows [開始]\[程式集] 功能表
[StartupFolder] | Windows Start\Programs 功能表中的 [啟動] 資料夾
[DesktopFolder] | Windows [桌面] 資料夾
[INSTALLLOCATION] | 安裝 Office 的資料夾
[FavoritesFolder] | 使用者的 [我的最愛] 資料夾
[AppDataFolder] | 使用者的 Application Data 資料夾
[NetHoodFolder] | 使用者的 [網路上的芳鄰] 資料夾
名稱 - 輸入任意字串來指定捷徑的名稱。
開始位置 - 透過輸入路徑，指定應用程式的預設開始資料夾。如果將這個方塊留白，預設資料夾便會設定為目標檔案所在的資料夾。如果路徑對使用者的電腦無效，當使用者嘗試使用捷徑時，便會出現錯誤訊息。
引數 - 在命令列上輸入要傳遞至應用程式的選用引數。
快速鍵 - 輸入應用程式或檔案的選用快速鍵。快速鍵的語法為：
[modifier+]VK_key
其中 modifier 為 SHIFT、CTRL、ALT 或 EXT，而 VK_key 為虛擬按鍵名稱 (請參閱下表)。輔助按鍵是選用的，而且您可以按照任何順序指定一個以上的輔助按鍵，並以加號 (+) 隔開。如果您使用輔助按鍵，它就必須出現在虛擬按鍵名稱前面。您必須輸入一個虛擬按鍵名稱。此外，請勿在按鍵定義中使用空格。

這裡有一些範例：

CTRL+VK_F12
CTRL+SHIFT+VK_A
ALT+CTRL+VK_SNAPSHOT

某些組合鍵 (例如 CTRL+ALT+VK_DELETE) 可能已經由系統所使用，而且可能無法如預期方式啟動應用程式。請避免在使用者電腦上發生衝突，尤其是在指定不含輔助按鍵的快速鍵時。例如，如果您指定不含輔助按鍵的 VK_A，每次使用者輸入 A 按鍵時，應用程式就會執行。

您可以使用下列虛擬按鍵名稱：
虛擬按鍵名稱 | 十六進位按鍵代碼 | 說明
VK_0 ... VK_9 | 30-39 | 按鍵 0-9
VK_A ... VK_Z | 41-5A | 按鍵 A-Z
VK_NUMPAD0 ... VK_NUMPAD9 | 60-69 | 數字鍵台上的按鍵 0-9
VK_F1 ... VK_F24 | 70-87 | 功能鍵 F1-F24
VK_LBUTTON | 1 | 滑鼠左鍵
VK_RBUTTON | 2 | 滑鼠右鍵
VK_CANCEL | 3 | 控制項中斷處理
VK_MBUTTON | 4 | 滑鼠中間鍵 (三個按鍵的滑鼠)
VK_BACK | 8 | 退格鍵
VK_CLEAR | 0C | CLEAR 鍵
VK_RETURN | 0D | ENTER 鍵
VK_PAUSE | 13 | PAUSE 鍵
VK_CAPITAL | 14 | CAPS LOCK 鍵
VK_PRIOR | 21 | PAGE UP 鍵
VK_NEXT | 22 | PAGE DOWN 鍵
VK_END | 23 | END 鍵
VK_HOME | 24 | HOME 鍵
VK_LEFT | 25 | 向左鍵
VK_UP | 26 | 向上鍵
VK_RIGHT | 27 | 向右鍵
VK_DOWN | 28 | 向下鍵
VK_SELECT | 29 | SELECT 鍵
VK_EXECUTE | 2B | EXECUTE 鍵
VK_SNAPSHOT | 2C | PRINT SCREEN 鍵
VK_INSERT | 2D | INS 鍵
VK_HELP | 2F | HELP 鍵
VK_MULTIPLY | 6A | 乘號鍵
VK_ADD | 6B | 加號鍵
VK_SEPARATOR | 6C | 分隔符號鍵
VK_SUBTRACT | 6D | 減號鍵
VK_DECIMAL | 6E | 小數點鍵
VK_DIVIDE | 6F | 除號鍵
VK_NUMLOCK | 90 | NUM LOCK 鍵
VK_SCROLL | 91 | SCROLL LOCK 鍵
執行 - 選取應用程式或檔案的預定起始視窗類型 ([標準視窗]、[最小化] 或 [最大化])。
變更圖示 - 為捷徑選取不同的圖示。